Last Comment Bug 381114 - Crash [@ msaa/nsAccessibleWrap::NativeAccessible ]
: Crash [@ msaa/nsAccessibleWrap::NativeAccessible ]
Status: RESOLVED FIXED
: access, crash, fixed1.8.1.5
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All Windows XP
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 18:51 PDT by Aaron Leventhal
Modified: 2011-06-09 14:58 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Null checks (2.64 KB, patch)
2007-05-17 18:52 PDT, Aaron Leventhal
no flags Details | Diff | Splinter Review
Null checks (1.22 KB, patch)
2007-05-17 18:53 PDT, Aaron Leventhal
no flags Details | Diff | Splinter Review
For 1.8.1 branch (1.27 KB, patch)
2007-05-17 19:02 PDT, Aaron Leventhal
mats: review+
dveditz: approval1.8.1.5+
Details | Diff | Splinter Review
Correct patch for trunk (1.23 KB, patch)
2007-05-17 19:03 PDT, Aaron Leventhal
mats: review+
Details | Diff | Splinter Review

Description Aaron Leventhal 2007-05-17 18:51:12 PDT
If nsnull is passed in, we crash. That happens if the caller wasn't able to get an nsIAccessible.
Comment 1 Aaron Leventhal 2007-05-17 18:52:35 PDT
Created attachment 265190 [details] [diff] [review]
Null checks
Comment 2 Aaron Leventhal 2007-05-17 18:53:14 PDT
Created attachment 265191 [details] [diff] [review]
Null checks
Comment 3 Aaron Leventhal 2007-05-17 19:02:45 PDT
Created attachment 265193 [details] [diff] [review]
For 1.8.1 branch
Comment 4 Aaron Leventhal 2007-05-17 19:03:53 PDT
Created attachment 265194 [details] [diff] [review]
Correct patch for trunk
Comment 5 Mats Palmgren (:mats) 2007-05-17 19:34:31 PDT
Comment on attachment 265194 [details] [diff] [review]
Correct patch for trunk

Looks good.  I would add an NS_ERROR before the return to catch
future mistakes.  Either way, r=mats
Comment 6 Mats Palmgren (:mats) 2007-05-17 19:35:00 PDT
Comment on attachment 265193 [details] [diff] [review]
For 1.8.1 branch

ditto, r=mats
Comment 7 Aaron Leventhal 2007-05-17 20:03:45 PDT
Checked in on trunk with NS_WARNING
Comment 8 Daniel Veditz [:dveditz] 2007-06-25 11:08:44 PDT
Comment on attachment 265193 [details] [diff] [review]
For 1.8.1 branch

approved for 1.8.1.5, a=dveditz for release-drivers
Comment 9 Mats Palmgren (:mats) 2007-07-01 11:11:35 PDT
Looks like Aaron checked in the branch patch on MOZILLA_1_8_BRANCH 2007-06-29:
accessible/src/msaa/nsAccessibleWrap.cpp  rev. 1.31.4.4
Comment 10 Stephen Donner [:stephend] 2007-07-10 18:35:47 PDT
Is there an end-user testcase to reproduce this, or can we just check talkback/breakpad, to verify?

Note You need to log in before you can comment on or make changes to this bug.