Orca only read the top of URL location that you visited before

RESOLVED DUPLICATE of bug 380976

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 380976
11 years ago
11 years ago

People

(Reporter: lijuan wang, Unassigned)

Tracking

({access})

Trunk
All
Linux
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Firefox trunk:
Minefield version 3.0a5pre 20070517

Reproduce Steps:
1. Press  <Ctrl+L> to focus on  URL location text field
2. Input www. there will list the urls which you visited before
3. Press <Down> arrow key to focus www.google.org
4. Press <Enter>

Respected Result:
After#3:Orca reads every URL location why pressing <Down> arrow key

Actual Result:
After#3:Orca only reads the top of URL location that you visited before.It won't read the second,third .....locations.

Comment 1

11 years ago
Confirmed.  I'm wondering if this is a dup of 380976.

I cannot (figure out how to) use Accerciser to examine the hierarchy of the table cells in the Location autocomplete because you cannot have the autocomplete expanded and be in Accerciser at the same time.  That said.... 

The object index we're getting for the table cells in this autocomplete is consistently -1 rather than the proper value.  And, as with 380976, the problem is with a tree table AND the problem was introduced with the 5/09 build.  Using the 5/08 build or earlier, Orca provides access to these items as expected.

Comment 2

11 years ago
Great detective work -- probably the same cause as bug 380976.

Comment 3

11 years ago
Since the date is the same and it's clear how we messed up tree views on that date, I'm going to mark this a dupe of the other tree view bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380976
You need to log in before you can comment on or make changes to this bug.