Sometimes Orca reads one character for several times continuously

RESOLVED INVALID

Status

()

Core
Disability Access APIs
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: lijuan wang, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access})

Trunk
All
Linux
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Firefox trunk:
Minefield version 3.0a5pre 20070517

Reproduced Steps:
1. Launch Minefied
2. Press <F1> to open help window.
3. Press <F7> to turn on/off caret browsing.
4. Read the content with arrow keys.

Respected Result:
After #3,#4: Orca reads the content character by character with arrow keys.
for example: name, should read as 'n','a','m','e'

Actual Result:
After #3,#4: Press arrow key quickly for some times and then Orca reads one character for several times continuously until you press arrow key.
for example: name, should read as 'n','n','n','a','a','a','m','m','m','e','e','e'

Comment 1

11 years ago
With the latest Orca and Minefield, I cannot reproduce this behavior.  How reliably can you reproduce this, and with which version/build of Orca? If it's pretty reliable my guess is that we're getting extra events.  It would be helpful to have a full debug.out taken when the problem is occurring. To do this, locate your user-settings.py file in ~/.orca and uncomment the following lines:

#orca.debug.debugLevel = orca.debug.LEVEL_ALL
#orca.debug.eventDebugLevel = orca.debug.LEVEL_OFF
#orca.debug.debugFile = open('debug.out', 'w', 0)

Then launch Orca and reproduce the problem.

I have opened an Orca bug to track this bug.  Because right now the bug is that Orca is doing the wrong thing, it might make sense to attach the debug.out to the Orca bug.  If we then determine that the bug is indeed with Firefox, we can update things here.  The Orca bug can be found at: http://bugzilla.gnome.org/show_bug.cgi?id=439467

Thanks!
(Assignee)

Updated

11 years ago
Assignee: nobody → aaronleventhal
Blocks: 374212
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
(Reporter)

Comment 2

11 years ago
Orca 2.18.1

Actual Result:
After #3,#4: 
Press arrow key(left or right)continuously and quickly for some times and then press in normal speed.Orca reads one character for several times continuously.

Follow Joanmarie Diggs 's steps, I add bug.out as an attachment.
(Reporter)

Comment 3

11 years ago
Created attachment 265474 [details]
~/debug.out

Updated

11 years ago
Attachment #265474 - Attachment mime type: application/octet-stream → text/plain

Comment 4

11 years ago
Thanks Lijuan.  I looked over your debug.out and I see where the problem is occurring.

1. The issue is not a Firefox one, but an Orca one.  

2. I *can* reproduce this in Orca 2.18.1.  However, sometime between then and the current version of Orca (2.19.3 pre) this issue was fixed -- at least for me.  Therefore, if you wouldn't mind giving the latest Orca from svn trunk a try and see if it's fixed for you, that would be great.  Please report your findings on the GNOME bug as this is not a Firefox issue.

Thanks again!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 5

11 years ago
Hi Joan, I tried this with latest orca and firefox, it's fixed and not reproducible anymore.
I have transfered this information to Lijuan, she also gives me same answer.
Thanks!
You need to log in before you can comment on or make changes to this bug.