Last Comment Bug 381276 - Allow "moves" as copies for cards to mailing lists
: Allow "moves" as copies for cards to mailing lists
Status: RESOLVED FIXED
: fixed-seamonkey1.1.3, verified1.8.1.5
Product: MailNews Core
Classification: Components
Component: Address Book (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Mark Banner (:standard8, limited time in Dec)
:
:
Mentors:
: 383113 (view as bug list)
Depends on:
Blocks: 349044
  Show dependency treegraph
 
Reported: 2007-05-19 11:49 PDT by Mark Banner (:standard8, limited time in Dec)
Modified: 2008-07-31 04:30 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Allow "moves" as copies for cards to mailing lists (1.23 KB, patch)
2007-05-19 11:49 PDT, Mark Banner (:standard8, limited time in Dec)
mozilla: review+
mozilla: superreview+
mscott: approval1.8.1.5+
Details | Diff | Splinter Review

Description Mark Banner (:standard8, limited time in Dec) 2007-05-19 11:49:19 PDT
Created attachment 265362 [details] [diff] [review]
Allow "moves" as copies for cards to mailing lists

See the various multiple duplicates filed referenced from bug 349044.

The problem is when I did the drag/drop fix-up I enforced copying to mailing lists, but the default was still move. Unfortunately it appears most users don't know about the ctrl/shift combinations for drag and drop.

Therefore with this patch I'm allowing "moves" to mailing lists to act as copies. canDrop is the only bit that needs to change as onDrop automatically enforces a copy to mailing lists.

I'd still like to have bug 349044 fixed, but I can't see a way to do it in our current implementation. So this bug will fix it so that most users will be able to copy to mailing lists, and bug 349044 will hopefully change the default to copy at some stage.

Note I'm intending to land this on branch once I've been able to confirm it works ok.
Comment 1 David :Bienvenu 2007-05-19 12:41:44 PDT
Comment on attachment 265362 [details] [diff] [review]
Allow "moves" as copies for cards to mailing lists

this will be a big improvement, thx, mark
Comment 2 Mark Banner (:standard8, limited time in Dec) 2007-05-20 04:33:20 PDT
Patch checked into trunk, I'll leave the bug open until we get branch approvals.
Comment 3 Mark Banner (:standard8, limited time in Dec) 2007-05-21 04:34:43 PDT
(In reply to comment #0)
> Created an attachment (id=265362) [details]
...
> Note I'm intending to land this on branch once I've been able to confirm it
> works ok.

btw the patch worked fine on branch as well as trunk.
Comment 4 Mark Banner (:standard8, limited time in Dec) 2007-05-30 13:30:12 PDT
Marking as fixed, I'll check in to branch once approval is given.
Comment 5 Mark Banner (:standard8, limited time in Dec) 2007-06-04 03:28:08 PDT
*** Bug 383113 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Veditz [:dveditz] 2007-06-26 15:36:46 PDT
Deferring approval to mscott
Comment 7 Stephen Donner [:stephend] 2007-07-11 16:25:01 PDT
Looks like there is tree problem in that when I copy the "foo" mailing list from Personal Address Book over to Collected Address Book, although it's populated in the latter, there is no twisty indicating the CAB has content, but clicking on its top-level element shows that it does indeed exist (I'll have to look this separate bug up and file, if necessary).

(I know we've had this bug on the trunk for a while, but I didn't think it affected branch, until now.)

However, the original issue is verified FIXED on "version 2.0.0.5pre (20070711)" using Windows XP SP2.

Replacing fixed1.8.1.5 keyword with verified1.8.1.5

Note You need to log in before you can comment on or make changes to this bug.