SeaMonkey lacks a "session saver" feature

RESOLVED DUPLICATE of bug 36810

Status

SeaMonkey
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 36810
10 years ago
10 years ago

People

(Reporter: Andrew Ramage, Unassigned)

Tracking

Bug Flags:
blocking-seamonkey2.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has workaround] [Firefox-parity])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.2) Gecko/20070224 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.2) Gecko/20070224 SeaMonkey/1.1.1

I usually have at least four pages open in tabs.  Closing Seamonkey causes all pages to close (which is as expected) but when starting only the page that had focus when Seamonkey was closed is remembered.  This contrasts with Firefox, which rmembers all open tabs.

Reproducible: Always

Steps to Reproduce:
1. Open several pages in the Seamonkey browser.
2. Close Seamonkey
3. Reopen Seamonkey
Actual Results:  
Only the last page visited is reopened

Expected Results:  
All pages open when the browser was closed should reopen.
(Reporter)

Updated

10 years ago
Version: unspecified → SeaMonkey 1.1 Branch
Unlike Firefox, SeaMonkey hasn't got a "session saver" feature yet. In the meantime, you can use the following (WORKAROUND):

1. (once and for all) Under Edit -> Preferences -> Browser, select whatever it takes to load the home page at startup. (It may vary between versions)
2. (before every shutdown) In the same page of the Preferences, set your "Home Tab" to "Use Current Group".
3. Close SeaMonkey.
4. Reopen SeaMonkey.

Result: All tabs reopen with their previous contents.

--------------------
Summary and Severity changed to reflect the need for a session saver feature in SeaMonkey.
Assignee: general → nobody
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Component: General → Preferences
Ever confirmed: true
OS: Linux → All
QA Contact: general → prefs
Hardware: PC → All
Summary: Only one page is kept when Seamonkey restarts → SeaMonkey lacks a "session saver" feature
Whiteboard: [has workaround] [Firefox-parity]
Flags: blocking-seamonkey2.0a1?

Comment 2

10 years ago
Such feature work does not block a release. It may be a nice addition, but it's not keeping us from releasing anything, esp. not a testing version, i.e. an alpha.
Severity: trivial → enhancement
Flags: blocking-seamonkey2.0a1? → blocking-seamonkey2.0a1-
Version: SeaMonkey 1.1 Branch → Trunk
Duplicate of this bug: 36810

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 36810
You need to log in before you can comment on or make changes to this bug.