customizable one-click (hidden) form submission

RESOLVED WONTFIX

Status

SeaMonkey
Search
P3
enhancement
RESOLVED WONTFIX
18 years ago
10 years ago

People

(Reporter: André Langhorst, Unassigned)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I´m sorry, couldn´t find a better summary, because I did not know how to name
that small box left next to the url field in the navigation bar, which pops up
"get a quote" - "get local information" etc.
What, if the user could customize the options in this box, but not only could
pick some from a range of standard options...
Example: The user uses a site to retrieve telephone numbers and has to enter for
example "name" and "zip code" in a form and submits it then. It would be much
easer if the user clicks in mozilla "get telephone number" (had has to create
this option before) and in the url field would appear "keyword:telephoneno
[Enter name here],[Enter zip code here] . Mozilla than fills out these fields
(which mozilla had remembered during the customize process) and submits the form.
I think it could be some work to implement this, but if many users think it´s
usefull, why not?

Comment 1

18 years ago
I'm not sure I can really understand this bug report. I think what you are
saying is that you want the little menu in the URL bar to have items for
commonly required pieces of information like phone number, zip code etc. You can
then select this and it will insert them in the URL bar. I don't know if that
would be terribly useful because most sites wouldn't support this format. Isn't
it Autofills job to do this sort of thing anyway? Moving to Autofill.
Component: Browser-General → Autofill
(Reporter)

Comment 2

18 years ago
it´s in fact similar to autofill, but
1.) user does not need to open the page containing the form
2.) user can select one ore more field (during the inital customization
process), in which his input in the url bar should be filled

for example I could myselft register a "show bug nr" entry, then I could open
bugs directly with for example keyword:bug 38137

I think this is useful

Comment 3

18 years ago
Sounds a lot like bug 29871.
(Reporter)

Comment 4

18 years ago
no,  bug 29871 is similar, but not as useful as this one, I think of this way:
** customization **
1.) user enters a page with a form
2.) user decides to use (or maybe uses already) this page frequently
3.) user activates the "track ??? option"
4.) mozilla remembers all fields and prompts the user to select one or fields he
wants to "customize"
5.) the user assigns names to these fields and a name for the new option in the
small menu in the url bar
** use **
6.) the user clicks on the new option in the small menu bar
7.) in the url bar appears [name of the new option] [field1] [field2] for
example "show bug [enter bug nr]"
(Reporter)

Comment 5

18 years ago
another way to use this function: whois queries (on nic forms), price queries on
a product of interest... etc.

Comment 6

18 years ago
I'm not sure you couldn't do all of that with the solution presented in 29871
though. Asa mentioned he was going to set it up to take bugzilla numbers so you
could type in (say) "bug 33457" and it would take you to
"bugzilla.mozilla.org/show_bug.cgi?id=33457". If you can do that with bugzilla
numbers, surely you could do it with any of the other things.

Comment 7

18 years ago
reassign
Assignee: asadotzler → morse
QA Contact: jelwell → sairuh

Comment 8

18 years ago
I'm not following this completely, but it sounds like the current wallet 
(autofill) feature provides the same functionality.  Therefore I am not 
motivated to implement this.  I'll assign it to nobody@mozilla.org so that if 
someone wants to volunteer to implement this, he can assign it to himself.
Assignee: morse → nobody
(Reporter)

Comment 9

18 years ago
autofill (current):
- not saveable as an option in the small menu left to the url bar
- get method only
- only once possibilty to fill out a particular form
1.) type the url/click a bookmark
2.) wait until autofill fills the fields - keep in mind (if I´m not wrong),
there´s only one way autofil fills the field, example: I want to autofill the
mozilla query form, but I want to have different options, option a) querying my
bugs (including unconfirmed), option b) querying a particular component on bugs
c) etc. - I can´t let autofill do that, am I wrong? Autofill only fills case A,B
or C(...)
3.) Click, to submit the form
4.) result appears

custom keyword (current):
- (i think) it only works with method GET (or I´ve to review source and then I
do not know if GET variables are used it the form uses POST)
- it only works with ony variable, but what if there are two ore more variables
- not saveable as an option in the small menu left to the url bar, too

requested feature:
a) could work like the custom keyword thing if one could define more variables
b) could work with a customization manager which analyzes the form and from
which one could choose which fields to customize

i hope I could clarify my request

Comment 10

18 years ago
Current autofill does allow you to have several different choices for the 
various fields.  You get a preview screen showing the values that will be filled 
in for each field.  These values are presented as dropdown lists that show 
alternates values for that field.
(Reporter)

Comment 11

18 years ago
hmm, I think autofill and custom keywords (btw, I didn´t these custom keywords
workin, instead mozilla searched at google) both cannot fulfill what I
requested, maybe someone cares about later...
confirming this --but since it's assigned to nobody, adding helpwanted kw.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted

Comment 13

18 years ago
Changing component to Search, since this would probably be tied to the Sherlock 
plugins that a user can add ....

M Future
Component: Autofill → Search
QA Contact: sairuh → claudius
Target Milestone: --- → Future
Netscape nav triage team: as per Matt Fisher's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-
Something equivalent to this is now available in Firefox. WONTFIX, for lack of a
better option.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 94962
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.