allow easy bookmarks queries

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
consumers shouldn't need to use the complex-query infrastructure in order to do simple bookmarks queries. we should expose a public api off of the bookmarks service that takes a folder id and returns a result node for that folder.

could possibly rename and expose nsNavBookmarks::ResultNodeForFolder, or a simpler version that only takes a folder id.
Uhm, why is this blocking bug 380250? I think you meant a different bug, right?
(Reporter)

Updated

12 years ago
No longer blocks: 374420
(Reporter)

Updated

12 years ago
Duplicate of this bug: 330307
(Reporter)

Comment 3

10 years ago
it's easy to write wrappers for this, extensions can use PlacesUtils or FUEL -> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.