clipping on absolute positioned boxes moved by javascript

RESOLVED FIXED

Status

()

Core
Layout: R & A Pos
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 265795 [details]
screenshot

STR
1. load url (Fx Tinderbox)
2. click on name in the guilty column
result
1a. the little popup box that comes up is partly clipped.
1.b also, it takes part of the background with it of the table-cell behind it with it.

scrolling up/down the page restores the display

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre ID:2007052223 [cairo]

-0-
Eli, probably one of yours
(Reporter)

Comment 1

11 years ago
Regressed between 2007-05-22-17 and 2007-05-22-18

that fingers bug 379015, I think.

works
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre ID:2007052217 [cairo]
Fails
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre ID:2007052218 [cairo]
Blocks: 379015

Comment 2

11 years ago
Can you check a 2007-05-22-19 build? It's much more likely to be bug 380438; the checkin for bug 379015 shouldn't have resulted in any visible changes.
(Reporter)

Comment 3

11 years ago
Ok, my bonsai query was wrong, the 2007052218 build indeed has the patch for bug 380438.
Changing the dependency accordingly.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre ID:2007052218 [cairo]
Blocks: 380438
No longer blocks: 379015

Updated

11 years ago
Depends on: 381746
(Reporter)

Comment 4

11 years ago
The problem was fixed by the patch in bug 381746.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070526 Minefield/3.0a5pre ID:2007052620 [cairo]
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.