Closed Bug 381908 Opened 14 years ago Closed 14 years ago

Update Extensions doesn't use proxy

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 312473

People

(Reporter: markb, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When I start up Firefox, and it is determined that there is a new update
to an extension, a dialog is displayed allowing me to install it before
Firefox starts up.

Unfortunately, when I say Yes, meaning I'd like to install the update,
it fails.  Since I never get a dialog asking for proxy username and
password, I assume the update failure is due to the proxy login not
having been accomplished yet at this point. 

Reproducible: Always

Steps to Reproduce:
Start Firefox in an environment that require a proxy with user name & password
when a new update for an extension is available, wait for the dialog, and
tell it to install the update.


Actual Results:  
The update fails.

Expected Results:  
The proxy should be enabled and the update should succeed.

If I say "no" to the auto-update, wait for Firefox to finish starting up
select Tools -> Add-ons and then click Find Updates, the update works.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312473
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.