Last Comment Bug 382015 - Handle old/new API behavior of cairo_{fill,stroke}_extent on branch
: Handle old/new API behavior of cairo_{fill,stroke}_extent on branch
Status: RESOLVED FIXED
: fixed1.8.1.5
Product: Core
Classification: Components
Component: SVG (show other bugs)
: 1.8 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://lists.freedesktop.org/archives...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 09:21 PDT by tor
Modified: 2010-09-18 08:30 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
don't depend on API bug (7.91 KB, patch)
2007-05-25 09:21 PDT, tor
jwatt: review+
roc: superreview+
dveditz: approval1.8.1.5+
Details | Diff | Review

Description tor 2007-05-25 09:21:01 PDT
Created attachment 266077 [details] [diff] [review]
don't depend on API bug

Since linux distributors can't seem to understand "--enable-system-cairo is unsupported", we need to change the branch SVG code to handle both the old and new API behavior of cairo_{fill,stroke}_extent.
Comment 1 Sylvain Pasche 2007-05-25 12:20:28 PDT
I can confirm this fixes the issue mentioned on https://bugs.launchpad.net/fedora/+source/firefox/+bug/99368 or https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232796
Comment 2 Jonathan Watt [:jwatt] 2007-06-12 05:46:32 PDT
What is the API bug that we don't want to depend on?
Comment 3 Sylvain Pasche 2007-06-12 06:05:43 PDT
Here's the commit Tim found that fixes the API bug in question: http://gitweb.freedesktop.org/?p=cairo.git;a=commitdiff;h=a8ca155f83098c02fb8d3acc57b0492d5b753d54

"Correctly return the transformed bounding box for stroke/fill extents,
instead of just transforming the two corners separately."
Comment 4 Jonathan Watt [:jwatt] 2007-06-13 07:51:09 PDT
Thanks Sylvain.
Comment 5 tor 2007-06-21 08:17:08 PDT
Comment on attachment 266077 [details] [diff] [review]
don't depend on API bug

Linux distributors have been ignoring our advice that --enable-system-cairo is unsupported and are running Firefox against newer versions of cairo than what's in the tree.  The branch svg code relied on a bug in one of the cairo APIs that has since been fixed.  This patch moves similar fixes that were made to the trunk about half a year ago, and makes the code work with both old and new behavior.
Comment 6 Daniel Veditz [:dveditz] 2007-06-28 11:39:30 PDT
Comment on attachment 266077 [details] [diff] [review]
don't depend on API bug

approved for 1.8.1.5, a=dveditz for release-drivers
Comment 7 tor 2007-06-28 12:38:57 PDT
Checked in on MOZILLA_1_8_BRANCH.

Note You need to log in before you can comment on or make changes to this bug.