99% cpu time executing java script

RESOLVED DUPLICATE of bug 167884

Status

()

--
critical
RESOLVED DUPLICATE of bug 167884
11 years ago
11 years ago

People

(Reporter: geisterfunk, Unassigned)

Tracking

1.5.0.x Branch
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.6) Gecko/20060803 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.6) Gecko/20060803 Firefox/1.5.0.6

entire system freeze during executing this java scipt (it comes to a 99% cpu useage time).

After displaying the options, when user switches from one option to another , one 
must wait 2-3 minutes until the menu is updated again.

Problem does not appear in windows (xp)


Reproducible: Always

Steps to Reproduce:
1.login into your ebay account.
2.enter url

Actual Results:  
firefox wil make the system unresponsable for at least the loading/execvuting time (2-3 minutes) and uses 99% cpu execution time for executing this java script.


Expected Results:  
Menu should be displayed within a few secounds, navigation inside should also be possible within secounds.
Does it do the same if you use a new firefox profile?
- http://kb.mozillazine.org/Profile_manager
(Do not delete your existing profile)
Also, you are on an old version of firefox.. the 1.5 branch is up to 1.5.0.11 now, but I am not familiar with your OS; maybe that is why your build is so old?

Updated

11 years ago
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Also, you are on an old version of firefox.. the 1.5 branch is up to 1.5.0.11
> now, but I am not familiar with your OS; maybe that is why your build is so
> old?
> 

It doesnt matter wich version of firefox i'm using.
I tried 1.5 and all 2.0.x version, up to the latest one 2.0.0.3

Even very old version (from 2003 and older [mozilla]  has this problem.
As already told,  this seems to be a problem only apering on OS/2 systems (i got told that it is the same on linux but can't confirm that).

It works with firefox 1.5 in windows xp Sp2
(Reporter)

Comment 4

11 years ago
(In reply to comment #1)
> Does it do the same if you use a new firefox profile?
> - http://kb.mozillazine.org/Profile_manager
> (Do not delete your existing profile)
> 

No it doesnt work with any profile.

It it something in the java script that OS/2 doesnt like somehow.

It always happen when a new window opens over the existing one.

After waiting a few seconds one can see windows with a loading progress displaying some round circles witch switch from transparent color to black / brown color
after a total loading time from 2-3 minutes you can see the menu.


Comment 5

11 years ago
I am not sure what led you to believe that there is Java or JavaScript involved and I don't see any the problem (and neither a Java applet nor particularly dangerous JavaScript) on the URL that you point to. But I think what you describe is bug 167884 which, because it is so obvious and unfixable on OS/2, was also added to README.txt. If you wait long enough, you should see that the background of the page has been overlayed by a semi-transparent layer, that eBay chose to use a small repeated PNG for.
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> I am not sure what led you to believe that there is Java or JavaScript involved
> and I don't see any the problem (and neither a Java applet nor particularly
> dangerous JavaScript) on the URL that you point to. But I think what you
> describe is bug 167884 which, because it is so obvious and unfixable on OS/2,
> was also added to README.txt. If you wait long enough, you should see that the
> background of the page has been overlayed by a semi-transparent layer, that
> eBay chose to use a small repeated PNG for.
> 
Hmm i dont know if it is java script problem at all, but when one disables the java script in the option thing it works (the window itself is then not shown)

This is at all not a fix more a workaround.

Sure when i wait 2-3 minutes on my 1700 Mhz machine i can see the window loading
with some transparency background.

Ok so when it is unfixable on OS/2 we need to tell ebay that they add some kind of fix (or a button to disable this stupid info window)  to the page so that os/2 users can use ebay again.











Comment 7

11 years ago
OK, resolving as duplicate.

I very much doubt that ebay cares about the odd OS/2 user selling things on their site... It's more work for them to change their pages than they would make through us. It's easier to find a workaround ourselves.

I just tried to find a workaround for you, but I cannot even find how to reach that stage of selling through them where the problem appears (everytime I try again it seems that they have forgotten that I was once allowed to sell). If it does, wait until everything is loaded, and press Ctrl-I to bring up the page info dialog. On the Media tab you then have to find the responsible semi-transparent PNG image. Once you know its location you can write a CSS rule for it to exclude it when displaying. This rule can then be placed in userContent.css. If you need more help with that, you are welcome to contact me by private email.

[P.S.: You should really not write "java script" there is no such thing. There is either "Java" (which normally manifests itself as an applet in the page) or "JavaScript", which is a scripting language mostly used on webpages (but also to create the user interface of Mozilla applications. Have a look at the respective Wikipedia articles.]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167884
You need to log in before you can comment on or make changes to this bug.