Closed Bug 382081 Opened 14 years ago Closed 14 years ago

Small downloads don't show in download manager when already open

Categories

(Toolkit :: Downloads API, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: mwu, Assigned: sdwilsh)

References

Details

(Keywords: regression)

Attachments

(1 file)

If a new download is started with the download manager open, it doesn't always show up in the download manager.

To reproduce:
1. open downloads manager
2. clear existing downloads
3. attempt to download a small file

The new download doesn't show in the downloads manager.
I'm pretty sure I know how to fix it.  This is all because we cannot use templates :(
Assignee: nobody → sdwilsh
Blocks: 380250
Attached patch v1.0Splinter Review
Basically, the template took care of this before.  Small files complete before the update interval, so they never got flagged as started.  Part of this is because I moved the dl-start notification there, but it needs to stay there.  The best part is that the unit tests verify that this doesn't break anything ;)

Anyway, this is one additional check each time this function is called, but it's just comparing too PRInt16s, so it's quick.  Too bad we have to do it though :(
Attachment #266168 - Flags: review?(mconnor)
Regardless of this working with or without the templates, it's still a bug.  I probably should add a test case as well.
Status: NEW → ASSIGNED
Flags: blocking-firefox3?
Summary: New downloads don't show in download manager when already open → Small downloads don't show in download manager when already open
Attachment #266168 - Flags: review?(mconnor) → review+
Checking in toolkit/components/downloads/src/nsDownloadManager.cpp;
new revision: 1.84; previous revision: 1.83
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3? → blocking-firefox3+
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081705 Minefield/3.0a8pre
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.