Using slash in the search box causes only the characters before the slash to be searched on.

VERIFIED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
--
minor
VERIFIED WONTFIX
11 years ago
11 years ago

People

(Reporter: John Lippincott, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4

I put this search into the search box: 9/11 memorial riverside church. I use Dogpile for my default search engine. The search only searched for "9".

Reproducible: Always

Steps to Reproduce:
1.enter test into search box
2. search
3.
Actual Results:  
It only searches for the characters before the backslash.

Expected Results:  
It only searches for the characters before the backslash.

It should have searched for all text in the search box.

Comment 1

11 years ago
We don't escape /, which apparently some search engines don't like, and I can't think of any reason not to go ahead and escape it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Using backslash in the search box causes only the characters before the backslash to be searched on. → Using slash in the search box causes only the characters before the slash to be searched on.
(In reply to comment #1)
> and I can't think of any reason not to go ahead and escape it.

It'll regress bug 341846, unless those two types of searches are handled differently.

(I also happen to think Dogpile is just broken, since it seems to need/perform some triple-escaping.)

Comment 3

11 years ago
I knew something about this seemed familiar. Thanks for finding that. I think it's funny that the reason I gave for going along with bug 341846 was RESTful URLs, and this is broken because they are using an non-query search URL (although it's clearly not really a RESTful scheme either).

Since this is a fringe case and the original change was to fix a legitimate problem, I guess this is WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.