Closed Bug 382188 Opened 15 years ago Closed 10 years ago

Separator lines in Bookmark Manager are (1 px) vertically misaligned

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Windows 2000
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sgautherie, Unassigned)

Details

(Keywords: polish, regression, Whiteboard: [2012 Fall Equinox])

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4pre) Gecko/20070519 SeaMonkey/1.1.2] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007052108 Minefield/3.0a5pre] (nightly) (W2Ksp4)

No bug.


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070527 SeaMonkey/1.5a] (nightly) (W2Ksp4)

1. Ctrl+B to open Bookmark Manager.
2. See that the Separator lines appear in the tree on the left;
2r. But the separator themselves are not drawn anymore: lines are blank.


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007052715 SeaMonkey/1.5a] (suiterunner, tinderbox-builds) (W2Ksp4)

The Separator is drawn;
But it is one pixel above the dotted line from the tree on the left.


I'm making a guess here (that this explains that):
*the tree part comes from "xpfe".
*while the separator part comes from "toolkit".

In which case, I believe
*the SM bug is a WontFix as we are about to switch Trunk to sr.
*the sr bug should be fixed, to improve look and feel.
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007053102
SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

(Unsurprisingly, bug still there with new Trunk SeaMonkey(/suiterunner).)
Keywords: polish
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111202 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

(Bug still there.)
Summary: Visual issues with Separator lines → Separator lines in Bookmark Manager are (1 px) vertically misaligned
This bug is open but targeted for seamonkey2.0a1, which has been released a long time ago. Please set the target milestone to an appropriate value, "---" if it has no specific target.
Flags: wanted-seamonkey2?
Target Milestone: seamonkey2.0a1 → ---
Both lines and separators are drawn by nsTreeBodyFrame with colours given by rules in global/tree.css (so we could only tweak the display of separators in Modern) however separators are defined as a two pixel groove which (given that the groove shadow looks like the background) makes them look one pixel higher.
I don't see any reason to give this special priority, but it's also not unwanted, so cancelling the wanted flag.

From what I read here, it might even be WONTFIX, or at least actually a toolkit tree bug, should we resolve or move it?
Flags: wanted-seamonkey2.0?
There are no separator lines in left part of Bookmarks Manager, is this still actual?
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA?]
Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0 SeaMonkey/2.16a1 ID:20121019003003 c-c:bd22a204044b m-c:0ff60bfb3442

Separators can be added by File → New Separator. The separator reaches to a millimeter or two to the right of the vertical line, and is prolonged by a dotted line exactly aligned with the separator.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA?] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.