Status

()

enhancement
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: okazaki, Assigned: kaie)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (X11; U; FreeBSD amd64; en-US; rv:1.8.1.3) Gecko/20070523 Firefox/2.0.0.3
Build Identifier: 

add support for Camellia(RFC4132) when NSS 3.12 is for firefox-trunk.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Depends on: 361025
Please request review on both patches from kengert@redhat.com, once you're ready to do so.
Assignee: kengert → okazaki
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Depends on: nss312
Please review both patches since NSS 3.12 alpha1 is into fx 3.0.
Assignee: okazaki → kengert
Hi Kai- could I ask you to please review this patch before the next alpha release (or beta?)- thank you very much.
It seems 3.12 is back out for firefox-trunk,
please review 3.12 is import again.
The patch builds OK.

I would like to try connecting to a site that implements Camellia.

Is there a public server I could connect to for testing?
Thank you for checking camellia patch.
Camellia HP server supports Camellia.
http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html
(In reply to comment #8)
> Thank you for checking camellia patch.
> Camellia HP server supports Camellia.
> http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html

Thank you for this link.

I used your address with https: https://info.isl.ntt.co.jp/crypt/eng/camellia/index.html

When I use a Mozilla that uses the NSS 3.12 and the patch from this bug, when I connect to that address, page info says  "Camellia-256 256 bit"

Looks good to me.
Comment on attachment 266361 [details] [diff] [review]
patch for netwek/base/public/security-prefs.js

r=kengert
Attachment #266361 - Flags: review+
Comment on attachment 266360 [details] [diff] [review]
patch for security/manager/ssl/src/nsNSSComponent.cpp

r=kengert
Attachment #266360 - Flags: review+
Checked in
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.