crash while editing proxy preferences

VERIFIED DUPLICATE of bug 37597

Status

()

Core
XUL
P3
critical
VERIFIED DUPLICATE of bug 37597
18 years ago
18 years ago

People

(Reporter: Tom Everingham, Assigned: Peter Trudelle)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description:  Cannot change my proxy settings without crashing

Steps to Reproduce:
1.)  Select Edit | preferences... | Advanced | Proxies
2.)  Select the manual or automatic radio button
3.)  Try to edit an edit box where proxy names should go

Actual Results:  Crash

Expected Results:  should not crash

Build Date & Platform Bug Found:  
NT build 2000050412

Additional Builds and Platforms Tested On:
Crashes on Linux, didn't check the mac

Additional Information:

Stack trace:

nsXULRadioGroupElement::SetSelectedItem
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULRadioGroupElement.cpp, line 
91]
SetXULRadioGroupElementProperty 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsJSXULRadioGroupElement.cpp, line 
132]
js_SetProperty 
[d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2161]
js_Interpret 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2365]
js_Invoke 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 703]
js_InternalInvoke 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 776]
JS_CallFunctionValue 
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2796]
nsJSContext::CallEventHandler 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 791]
nsJSEventListener::HandleEvent 
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]
nsXBLEventHandler::ExecuteHandler 
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLEventHandler.cpp, line 452]
nsXBLEventHandler::MouseUp 
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLEventHandler.cpp, line 154]
nsEventListenerManager::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
769]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3301]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3326]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3326]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3326]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3326]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3326]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3326]
nsGenericElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 1038]
nsHTMLInputElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLInputElement.cpp, 
line 734]
PresShell::HandleEventInternal 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3410]
PresShell::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3340]
nsView::HandleEvent 
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 774]
nsView::HandleEvent 
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 747]
nsViewManager2::DispatchEvent 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1372]
HandleEvent 
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 531]
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 548]
nsWindow::DispatchMouseEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3360]
ChildWindow::DispatchMouseEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3565]
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2478]
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 781]
(Reporter)

Updated

18 years ago
Keywords: crash

Comment 1

18 years ago
is also a dup

*** This bug has been marked as a duplicate of 37597 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.