add support for Camellia to cmd/symkeyutil

RESOLVED FIXED in 3.12

Status

NSS
Tools
P3
enhancement
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: okazaki, Assigned: Neil Williams)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD amd64; en-US; rv:1.8.1.3) Gecko/20070523 Firefox/2.0.0.3
Build Identifier: 

In Bug 361025, a patch was dropped.
Could you apply this patch?


Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 266446 [details] [diff] [review]
patch for nss/cmd/symkeyutil
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → All
Target Milestone: --- → 3.12
Version: unspecified → 3.11
Assignee: nobody → neil.williams
Priority: -- → P3
(Assignee)

Comment 2

10 years ago
Attachment 266446 [details] [diff] applies to the trunk OK and I was able to generate a couple of Camellia keys with symkeyutil but the Camellia tests in all.sh fail. It appears that some of the bltests have not been checked in. I get

cvs server: cannot find module `nss/cmd/bltest/tests/camellia_ecb' - ignored
cvs [checkout aborted]: cannot expand modules
Status: NEW → ASSIGNED
Nail,  Any parts of the patch for bug 361025 that were not applied to 
the trunk should be considered part of this bug.  As you find files in
NSS that should have been changed, but whose patches were not apparently
committed, please note them in this bug, and attach patches for them to
this bug (probably the same patches found in bug 361025).
(Assignee)

Comment 4

10 years ago
Comment on attachment 266446 [details] [diff] [review]
patch for nss/cmd/symkeyutil

Please ignore comment 2. All QA test pass with this patch after all.
Attachment #266446 - Flags: review?(alexei.volkov.bugs)
(Assignee)

Comment 5

10 years ago
Comment on attachment 266446 [details] [diff] [review]
patch for nss/cmd/symkeyutil

Since I did not modify this patch I'll review it myself
Attachment #266446 - Flags: review?(alexei.volkov.bugs) → review?(neil.williams)
(Assignee)

Updated

10 years ago
Attachment #266446 - Flags: review?(neil.williams) → review+
(Assignee)

Comment 6

10 years ago
Checking in cmd/symkeyutil/symkey.man;
/cvsroot/mozilla/security/nss/cmd/symkeyutil/symkey.man,v  <--  symkey.man
new revision: 1.2; previous revision: 1.1
done
Checking in cmd/symkeyutil/symkeyutil.c;
/cvsroot/mozilla/security/nss/cmd/symkeyutil/symkeyutil.c,v  <--  symkeyutil.c
new revision: 1.10; previous revision: 1.9
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.