Last Comment Bug 382395 - Mexican Holiday Calendar
: Mexican Holiday Calendar
Status: VERIFIED DUPLICATE of bug 476234
:
Product: Calendar
Classification: Client Software
Component: Website (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 20:03 PDT by Alexandro Colorado
Modified: 2009-03-20 07:39 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ICS file (9.76 KB, patch)
2007-05-29 20:05 PDT, Alexandro Colorado
no flags Details | Diff | Splinter Review
SunBird converstion (9.67 KB, text/plain)
2007-06-17 15:06 PDT, Alexandro Colorado
no flags Details

Description Alexandro Colorado 2007-05-29 20:03:27 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040210 Netscape/7.1
Build Identifier: 

Mexican Holiday ICS file created in Evolution (sorry) It might be fixed by importing and exporting from sunbird unfortunately Evolution doesn't has an export ICS feature.

Reproducible: Always

Steps to Reproduce:
1.Open Sunbird
2.Import the MexicanHoliday.ics file
3.Export the calendar
Actual Results:  
Generate a Mozilla Compliant ICS file


BEGIN:VCALENDAR
CALSCALE:GREGORIAN
PRODID:-//Ximian//NONSGML Evolution Calendar//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:/softwarestudio.org/Olson_20011030_5/America/Belize
X-LIC-LOCATION:America/Belize
BEGIN:STANDARD
TZOFFSETFROM:-0600
TZOFFSETTO:-0600
TZNAME:CST
DTSTART:19700101T000000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:20070530T023150Z-7181-500-1-2@genius.homelinux.net
DTSTAMP:20070530T023150Z
DTSTART;VALUE=DATE:20070205
DTEND;VALUE=DATE:20070206
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día de la Constitución
CLASS:PUBLIC
CREATED:20070530T023242
LAST-MODIFIED:20070530T023950
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T023329Z-7181-500-1-4@genius.homelinux.net
DTSTAMP:20070530T023329Z
DTSTART;VALUE=DATE:20070224
DTEND;VALUE=DATE:20070225
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:La Bandera Mexicana
CLASS:PUBLIC
CREATED:20070530T023351
LAST-MODIFIED:20070530T024006
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T023247Z-7181-500-1-3@genius.homelinux.net
DTSTAMP:20070530T023247Z
DTSTART;VALUE=DATE:20070219
DTEND;VALUE=DATE:20070220
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día del Ejercito
CLASS:PUBLIC
CREATED:20070530T023325
LAST-MODIFIED:20070530T024024
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T023052Z-7181-500-1-1@genius.homelinux.net
DTSTAMP:20070530T023052Z
DTSTART;VALUE=DATE:20070106
DTEND;VALUE=DATE:20070107
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Dia de Reyes
CLASS:PUBLIC
CREATED:20070530T023146
LAST-MODIFIED:20070530T024035
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T022620Z-7181-500-1-0@genius.homelinux.net
DTSTAMP:20070530T022620Z
DTSTART;VALUE=DATE:20070101
DTEND;VALUE=DATE:20070102
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Año Nuevo
CLASS:PUBLIC
CREATED:20070530T023048
LAST-MODIFIED:20070530T024048
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T023428Z-7181-500-1-6@genius.homelinux.net
DTSTAMP:20070530T023428Z
DTSTART;VALUE=DATE:20070318
DTEND;VALUE=DATE:20070319
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Natalicio de Don Benito Juarez
CLASS:PUBLIC
CREATED:20070530T023507
LAST-MODIFIED:20070530T024106
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T023359Z-7181-500-1-5@genius.homelinux.net
DTSTAMP:20070530T023359Z
DTSTART;VALUE=DATE:20070318
DTEND;VALUE=DATE:20070319
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:La Expropiación Petrolera
CLASS:PUBLIC
CREATED:20070530T023424
LAST-MODIFIED:20070530T024113
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T023512Z-7181-500-1-7@genius.homelinux.net
DTSTAMP:20070530T023512Z
DTSTART;VALUE=DATE:20070414
DTEND;VALUE=DATE:20070415
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día de las Americas
CLASS:PUBLIC
CREATED:20070530T023539
LAST-MODIFIED:20070530T024122
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
END:VEVENT
BEGIN:VEVENT
UID:20070530T024209Z-7181-500-1-10@genius.homelinux.net
DTSTAMP:20070530T024209Z
DTSTART;VALUE=DATE:20070529
DTEND;VALUE=DATE:20070530
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Batalla de Puebla
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024226
LAST-MODIFIED:20070530T024226
END:VEVENT
BEGIN:VEVENT
UID:20070530T024326Z-7181-500-1-13@genius.homelinux.net
DTSTAMP:20070530T024326Z
DTSTART;VALUE=DATE:20070601
DTEND;VALUE=DATE:20070602
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Día de la Marina
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024352
LAST-MODIFIED:20070530T024352
END:VEVENT
BEGIN:VEVENT
UID:20070530T024359Z-7181-500-1-14@genius.homelinux.net
DTSTAMP:20070530T024359Z
DTSTART;VALUE=DATE:20070913
DTEND;VALUE=DATE:20070914
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Día de los Niños Heroes
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024455
LAST-MODIFIED:20070530T024455
END:VEVENT
BEGIN:VEVENT
UID:20070530T024502Z-7181-500-1-15@genius.homelinux.net
DTSTAMP:20070530T024502Z
DTSTART;VALUE=DATE:20070916
DTEND;VALUE=DATE:20070917
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Día de la Independencia
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024524
LAST-MODIFIED:20070530T024524
END:VEVENT
BEGIN:VEVENT
UID:20070530T023541Z-7181-500-1-8@genius.homelinux.net
DTSTAMP:20070530T023541Z
DTSTART;VALUE=DATE:20070430
DTEND;VALUE=DATE:20070501
TRANSP:OPAQUE
SEQUENCE:4
SUMMARY:Día del Niño
CLASS:PUBLIC
CREATED:20070530T023601
LAST-MODIFIED:20070530T024556
CATEGORIES:Holiday
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
BEGIN:VEVENT
UID:20070530T024233Z-7181-500-1-11@genius.homelinux.net
DTSTAMP:20070530T024233Z
DTSTART;VALUE=DATE:20070510
DTEND;VALUE=DATE:20070511
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día de las Madres
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024255
LAST-MODIFIED:20070530T024606
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
BEGIN:VEVENT
UID:20070530T024259Z-7181-500-1-12@genius.homelinux.net
DTSTAMP:20070530T024259Z
DTSTART;VALUE=DATE:20070515
DTEND;VALUE=DATE:20070516
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día del Maestro
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024321
LAST-MODIFIED:20070530T024621
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
BEGIN:VEVENT
UID:20070530T023605Z-7181-500-1-9@genius.homelinux.net
DTSTAMP:20070530T023605Z
DTSTART;VALUE=DATE:20070501
DTEND;VALUE=DATE:20070502
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día del Trabajo
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024203
LAST-MODIFIED:20070530T024644
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
BEGIN:VEVENT
UID:20070530T024701Z-7181-500-1-16@genius.homelinux.net
DTSTAMP:20070530T024701Z
DTSTART;VALUE=DATE:20070620
DTEND;VALUE=DATE:20070621
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Día del Padre
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024714
LAST-MODIFIED:20070530T024714
END:VEVENT
BEGIN:VEVENT
UID:20070530T024914Z-7181-500-1-20@genius.homelinux.net
DTSTAMP:20070530T024914Z
DTSTART;VALUE=DATE:20071101
DTEND;VALUE=DATE:20071102
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Día de todos los santos
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024948
LAST-MODIFIED:20070530T024948
END:VEVENT
BEGIN:VEVENT
UID:20070530T024915Z-7181-500-1-21@genius.homelinux.net
DTSTAMP:20070530T024915Z
DTSTART;VALUE=DATE:20071102
DTEND;VALUE=DATE:20071103
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Fiesta de Muertos
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T025014
LAST-MODIFIED:20070530T025014
END:VEVENT
BEGIN:VEVENT
UID:20070530T025016Z-7181-500-1-22@genius.homelinux.net
DTSTAMP:20070530T025016Z
DTSTART;VALUE=DATE:20071120
DTEND;VALUE=DATE:20071121
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Revolución Mexicana
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T025037
LAST-MODIFIED:20070530T025037
END:VEVENT
BEGIN:VEVENT
UID:20070530T025049Z-7181-500-1-25@genius.homelinux.net
DTSTAMP:20070530T025049Z
DTSTART;VALUE=DATE:20071212
DTEND;VALUE=DATE:20071213
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Nuestra Sra. de Guadalupe
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T025117
LAST-MODIFIED:20070530T025117
END:VEVENT
BEGIN:VEVENT
UID:20070530T025048Z-7181-500-1-24@genius.homelinux.net
DTSTAMP:20070530T025048Z
DTSTART;VALUE=DATE:20071225
DTEND;VALUE=DATE:20071226
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Navidad
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T025141
LAST-MODIFIED:20070530T025141
END:VEVENT
BEGIN:VEVENT
UID:20070530T025048Z-7181-500-1-23@genius.homelinux.net
DTSTAMP:20070530T025048Z
DTSTART;VALUE=DATE:20071224
DTEND;VALUE=DATE:20071225
TRANSP:OPAQUE
SEQUENCE:2
SUMMARY:Posadas Navideñas
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T025224
LAST-MODIFIED:20070530T025224
END:VEVENT
BEGIN:VEVENT
UID:20070530T024741Z-7181-500-1-17@genius.homelinux.net
DTSTAMP:20070530T024741Z
DTSTART;VALUE=DATE:20071012
DTEND;VALUE=DATE:20071013
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día de la Raza
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024803
LAST-MODIFIED:20070530T025306
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
BEGIN:VEVENT
UID:20070530T024842Z-7181-500-1-19@genius.homelinux.net
DTSTAMP:20070530T024842Z
DTSTART;VALUE=DATE:20071024
DTEND;VALUE=DATE:20071025
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día de las Naciones Unidas
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024904
LAST-MODIFIED:20070530T025338
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
BEGIN:VEVENT
UID:20070530T024806Z-7181-500-1-18@genius.homelinux.net
DTSTAMP:20070530T024806Z
DTSTART;VALUE=DATE:20071023
DTEND;VALUE=DATE:20071024
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:Día Nacional de la Aviación
CATEGORIES:Holiday
CLASS:PUBLIC
CREATED:20070530T024838
LAST-MODIFIED:20070530T025357
DESCRIPTION:http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
END:VEVENT
END:VCALENDAR
Comment 1 Alexandro Colorado 2007-05-29 20:05:19 PDT
Created attachment 266567 [details] [diff] [review]
ICS file

MexicanHoliday.ics ICS file containing mexican holiday extracted from http://www.e-mexico.gob.mx/wb2/eMex/eMex_Calendario_de_Fiesta
Comment 2 Simon Paquet [:sipaq] 2007-05-31 16:07:58 PDT
Alexandro, I'm extremely soory for saying this, but can you please create the holiday calendar with Lightning or Sunbird. We currently suck with regard to timezone definitions from other applications (see bug 314339). 

And the only way to avoid that currently, is to create a file in Lightning or Sunbird. 

Sorry!
Comment 3 Simon Paquet [:sipaq] 2007-06-17 12:49:40 PDT
Alexandro, any update from your side?
Comment 4 Alexandro Colorado 2007-06-17 15:06:46 PDT
Created attachment 268714 [details]
SunBird converstion

Here is the transformation, however I also saw some privacy issues like posting my server within the file. I had to download Sunbird and convert to it. 

Why does ICS are different, I thought ICS was an open standard which means it should be pretty compatible among applciations. Is this a bug?
Comment 5 Simon Paquet [:sipaq] 2007-06-18 10:00:02 PDT
Alexandro, thanks for your contribution. I've checked in the holiday calendar file. Yes, the issue I mentioned is a bug (bug 314339). See also comment 2.
Comment 6 Simon Paquet [:sipaq] 2009-01-05 05:52:44 PST
Hi Alexandro,
any interest in updating the calendar holiday file with the 2008, 2009 and (if it's possible) the 2010 holidays of Mexico?
Comment 7 Simon Paquet [:sipaq] 2009-03-15 03:39:06 PDT

*** This bug has been marked as a duplicate of bug 476234 ***

Note You need to log in before you can comment on or make changes to this bug.