"Grippies" for sidebar and similar panels missing in Suiterunner

RESOLVED FIXED

Status

defect
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: hand_of_fate2000, Assigned: neil)

Tracking

({fixed1.9.1})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070531 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070531 SeaMonkey/2.0a1pre

In the previous builds the sidebar and other similar panels had a button on their edge to collapse or expand the panel instantly, similar to the tool bar "grippies". In the suiterunner builds this feature is missing.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Confirming, this is a themes issue - toolkit's global splitter.css doesn't have the same as our original classic, we need to rework classic to get our grippies back.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Version: unspecified → Trunk
Just to add that this issue only applies to the "Default" theme. The grippies still appear as they should for the "modern" theme. I haven't tried any third-party themes.
This is a general *stripe issue, and it might be something to look in for toolkit as a whole. the grippy is the only part of the splitter which can be used for completely collapsing e.g. the sidebar with one click, and that might be something multiple apps want, not just SeaMonkey.
Assume I copy the appropriate images from themes/ where shown from the ? lines
Assignee: general → neil
Status: NEW → ASSIGNED
Attachment #266796 - Flags: review?(mano)
Comment on attachment 266796 [details] [diff] [review]
Proposed patch

>Index: toolkit/themes/pinstripe/global/jar.mn
>===================================================================
>RCS file: /cvsroot/mozilla/toolkit/themes/pinstripe/global/jar.mn,v
>retrieving revision 1.27
>diff -u -r1.27 jar.mn
>--- toolkit/themes/pinstripe/global/jar.mn	29 Jan 2007 17:36:19 -0000	1.27
>+++ toolkit/themes/pinstripe/global/jar.mn	31 May 2007 20:01:36 -0000
>@@ -161,6 +161,10 @@
> +  skin/classic/global/scrollbox/autorepeat-arrow-up.gif              (scrollbox/autorepeat-arrow-up.gif)
> +  skin/classic/global/scrollbox/autorepeat-arrow-up-dis.gif          (scrollbox/autorepeat-arrow-up-dis.gif)
> +  skin/classic/global/splitter/dimple.png                            (splitter/dimple.png)
>++  skin/classic/global/splitter/grip-hrz-after.gif                    (splitter/grip-hrz-after.gif)
>++  skin/classic/global/splitter/grip-hrz-before.gif                   (splitter/grip-hrz-before.gif)
>++  skin/classic/global/splitter/grip-vrt-after.gif                    (splitter/grip-vrt-after.gif)
>++  skin/classic/global/splitter/grip-vrt-before.gif                   (splitter/grip-vrt-before.gif)
> +  skin/classic/global/tabDragDrop/tabDragIndicator.png               (tabDragDrop/tabDragIndicator.png)
> +  skin/classic/global/toolbar/Lighten.png                            (toolbar/Lighten.png)
> +  skin/classic/global/toolbar/dropmark-nav.png                       (toolbar/dropmark-nav.png)


Why does pinstripe have have those overrides (+) in all those lines? Are they really needed?
Duplicate of this bug: 382642
Duplicate of this bug: 383870
Summary: "Grippies" for sidebar and similar panels missing in Suiterunner → "Grippies" and "twisties" for sidebar and similar panels missing in Suiterunner
I don't see this catching any any twisties in comment #0 or the patch. If there is an additional issue there, please file an additional bug but don't morph summaries of an existing one.
The dupes may be wrong, btw, as I don't see them being about sidebar or similar grippies.
Summary: "Grippies" and "twisties" for sidebar and similar panels missing in Suiterunner → "Grippies" for sidebar and similar panels missing in Suiterunner
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Just checked build 2008011002 and the panel collapse functionality is once again missing in the default theme under Linux, though it is there in the Windows version of the same release.

Is this a consequence of some native theming change in Toolkit? The Mozilla-style grippies have been replaced by GTK-style ones, but these do not have the collapse/un-collapse functionality of the Mozilla ones.
Status: RESOLVED → REOPENED
OS: All → Linux
Resolution: FIXED → ---
Ed:
Pleas do NEVER reopen a bug because the same symptoms are coming up in a different form, please file a NEW bug on that. The specific issue that has caused those symptoms back then has been fixed here, what you are seeing is probably a new problem that merely results in the same symptom for you.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
OS: Linux → All
Resolution: --- → FIXED
Actually, Ed is right - I forgot to patch gnomestripe.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Posted patch gnomestripe (obsolete) — Splinter Review
Oh well, seeing as the bug's reopened, I'll attach the fix here ;-)
Attachment #342773 - Flags: review?(gavin.sharp)
Posted patch correctedSplinter Review
Attachment #342773 - Attachment is obsolete: true
Attachment #342775 - Flags: review?(gavin.sharp)
Attachment #342773 - Flags: review?(gavin.sharp)
Attachment #342775 - Flags: review?(gavin.sharp) → review+
Pushed changeset cb5d1af6acbb to mozilla-central.
Status: REOPENED → RESOLVED
Closed: 12 years ago10 years ago
Resolution: --- → FIXED
Attachment #342775 - Flags: approval1.9.1?
Comment on attachment 342775 [details] [diff] [review]
corrected

Would like this landed on 1.9.1 to correct platform toolkit behaviour not used by Firefox that was forked before the previous fix landed.
Attachment #342775 - Flags: approval1.9.1? → approval1.9.1+
Pushed changeset 8fdd47a7ad89 to releases/mozilla-1.9.1
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.