Crash during startup[@ ReadCMAPTableFormat12]

RESOLVED FIXED in mozilla1.9alpha6

Status

defect
--
critical
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: SRLyon, Assigned: pavlov)

Tracking

({crash})

Trunk
mozilla1.9alpha6
x86
Windows XP
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070529 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070529 Minefield/3.0a5pre

Update to build 2007-05-29-2031, get "Crash Bang Boom" reporter window. Happen with every build after 2007-05-29-1542. Here's a link to the checkins during that regression time frame:

<a href="http://hourly-archive.localgho.st/win32/20070529_2031_checkins.html"> http://hourly-archive.localgho.st/win32/20070529_2031_checkins.html </a>


Reproducible: Always

Steps to Reproduce:
1.Update using your preferred method (Partial, zip, full install)
2.Start or restart MineField
3.
Actual Results:  
Crash reporter

Expected Results:  
Minefield should launch

I have a couple of the crash logs captured, can email(??) to someone if they will help.
Version: unspecified → Trunk
I'm pretty sure this has been fixed, download the latest nightly. Uninstall the busted build, and re-install the latest.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070531 Minefield/3.0a5pre Firefox/3.0 ID:2007053112 [cairo]
Downloaded and installed every hourly on the 29th. Something occurred in the range listed at the link above. There was a similar issue with the nightly on the 29th that had a respin, but this is after that. Consistent crash with every build after 2007-05-29-1542
To answer your question, reports are stored in %appdata%\Mozilla\Firefox\Crash Reports in a "pending" or "submitted" folder. The name of the file will be a GUID. You can view a report by going to https://crash-reports.mozilla.com/reports/report/index/<GUID> where <GUID> is the GUID of the filename. (Soon we'll have a submit form for this on https://crash-reports.mozilla.com/reports, but you'll have to manually use the URL for now.)
Keywords: crash
(In reply to comment #3)
> To answer your question, reports are stored in %appdata%\Mozilla\Firefox\Crash
> Reports in a "pending" or "submitted" folder. The name of the file will be a
> GUID. You can view a report by going to
> https://crash-reports.mozilla.com/reports/report/index/<GUID> where <GUID> is
> the GUID of the filename. (Soon we'll have a submit form for this on
> https://crash-reports.mozilla.com/reports, but you'll have to manually use the
> URL for now.)
> 
Installed the 20070531-1813 hourly. Same result. Had it "send" one crash report, Crash ID: bp-2d8b2600-0fe3-11dc-b1f5-001a4bd43ef6 shows in the "Submitted" folder text file. Could not find it in the database using the link above, even after some hours. Had it create but not submit a second report. I zipped and emailed to Adam the dmp and extra files from that crash, hopefully they can make their way into the system with his assistance.
Crash ID for that one would be e082caf9-b45d-460d-b245-2c2843308d08 if it makes its way into the database.

Duplicate of this bug: 382714
Status: UNCONFIRMED → NEW
Ever confirmed: true
Per Adam, need to use a nightly for crash reports to have value, so tested with the 06-01-04 nightly. Not sure if breakpad is actually submitting the error reports since I can never find them using the UUID from the submitted text file. 

Might be related to profile or Profile Manager(?)...here's my reasoning:
1)Run firefox.exe without a profile existing, new profile is created but crash
2)Run firefox.exe with -safemode argument and no profile, new profile is created but crash
3)Run firefox.exe with -profilemanager argument and no profile, profile is NOT created but crash still occurs.
I'm going to go out on a limb and say this is the same startup crash:
https://crash-reports.mozilla.com/reports/report/index/366fd47d-0ee8-11dc-bf6c-001a4bd46e84
Summary: MineField will not start → Crash [@ ReadCMAPTableFormat12]
The report luser links to came from my machine; it indeed crashes with either -profilemanager, -safemode or nothing at all. 
Flags: blocking-firefox3?
Summary: Crash [@ ReadCMAPTableFormat12] → Crash during startup[@ ReadCMAPTableFormat12]
https://bugzilla.mozilla.org/show_bug.cgi?id=377950 (Need to get real cmaps from fonts) has been marked as fixed, but that did not fix my startup issue. The 2007-06-02-04 nightly still crashes in the same way.
Assignee: nobody → pavlov
Component: Startup and Profile System → GFX: Win32
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: startup → win32
With Sysinternals Process Monitor, I discovered that the last font it loads and the fonts it crashes on are fonts from Wolfram's Mathematica... deleted those and Minefield now starts up perfectly :-) There probably just needs to be some exception handling code on the font loading thing...
(In reply to comment #12)
I've got Mathematica (v5.2 for students) installed on my Vista machine and it works fine.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070603 Minefield/3.0a6pre ID:2007060304 [cairo]

On the other hand, the XP box that does exhibit the crashing also has Mathematica, and removing the fonts makes the more recent nightlies start up fine.
It would be good to know what fonts people are crashing on so that I can reproduce.  Can anyone reproduce this in the debugger?
OK. Guys, after reading your posts on Mathematica fonts crashing Minefield, I realized I had those special fonts for use with Abiword word processing program (http://www.abisource.com/) and BANG! After uninstalling those fonts, I can run Minefield again!

Stuart: You can find the fonts downloading the Abiword plugin:
http://web.mit.edu/atticus/www/mathml/mit-mathml-fonts-1.0-fc1.msi

I hope this helps...
(In reply to comment #15)
> OK. Guys, after reading your posts on Mathematica fonts crashing Minefield, I
> realized I had those special fonts for use with Abiword word processing program
> (http://www.abisource.com/) and BANG! After uninstalling those fonts, I can run
> Minefield again!
> 
> Stuart: You can find the fonts downloading the Abiword plugin:
> http://web.mit.edu/atticus/www/mathml/mit-mathml-fonts-1.0-fc1.msi
> 
> I hope this helps...
> 

Strange. I have them installed (just uninistalled and re-installed to check) and it doesn't crash Minefield here.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070605 Minefield/3.0a6pre - Build ID: 2007060504
Yes. Strange indeed. After reading your comment, I reinstalled the fonts and tried to launch Minefield. Crash! Bang! Bum! Crashed immediately. Tried again - crash again... Then, I uninstalled the fonts - Minefield initialize OK...

So, I can reproduce the crash at will by installed these fonts - at least here, that is...

Just in case, the package I've installed is MIT MathML Fonts 1.0 (as it is displayed on the Windows Add or Remove Programs. Do you have version 1.0 too?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070605 Minefield/3.0a6pre ID:2007060504 [cairo]
(In reply to comment #17)
> Just in case, the package I've installed is MIT MathML Fonts 1.0 (as it is
> displayed on the Windows Add or Remove Programs. Do you have version 1.0 too?
> 

Yes. When I re-installed I used the version you linked too. No idea what the difference could be here.
I can't reproduce the crash with the linked-to fonts :/
I sent Stuart the 2 Mathematica fonts that cause my system to fail. Sent them offline since they are copyrighted. Of the 28 fonts (7 fonts of 4 type/weights each) only 2 fonts cause the problem. They seem to be mathematica5m.ttf and mathematica5mb.ttf that cause the problem.
I can confirm. Having either installed causes Minefield to crash.
Confirmed here too. Installing either mathematica5m.ttf and
mathematica5mb.ttf causes a crash. Can be reproduced at will...
I can add to this that starting Mathematica here when Firefox is running causes Firefox to crash... never seen this kind of stuff before. Firefox also won't start when Mathematica is active. Mathematica is probably loading those fonts anyway and Firefox somehow gets involved. This was all reported by Talkback (not by the new crash reporter) so I don't have a crash id.
Flags: blocking1.9+
I'm going to try to find someone with Mathematica installed so I can debug this.. Just installing the fonts doesn't crash for me.
(In reply to comment #25)
> I'm going to try to find someone with Mathematica installed so I can debug
> this.. Just installing the fonts doesn't crash for me.
> 

I've had a trial version of Mathematica installed for a little while now and it doesn't crash here for me either.
Going to try to get this into A6, but hard to reproduce.  Per Stuart.
Target Milestone: --- → mozilla1.9alpha6
Posted patch v1.0 (obsolete) — Splinter Review
fix the old bogus code
Attachment #269719 - Flags: review?(robarnold)
actually, this won't fix the format12 crash but will fix a format4 one....
Comment on attachment 269719 [details] [diff] [review]
v1.0

nevermind, i filed 385793 on the format4 crash.
Attachment #269719 - Attachment is obsolete: true
Attachment #269719 - Flags: review?(robarnold)
anyone been able to reproduce this now with the new nightly symbols?  The only thing I can really think of is that aLength < 16...

I'll try sticking a NS_ENSURE_TRUE(aLength > 16, NS_ERROR_FAILURE); at the beginning of the function just incase...
WFM now in
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070626 Minefield/3.0a6pre ID:2007062604
WFM too!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070626 Minefield/3.0a6pre ID:2007062604
OK, I'm going to mark this fixed and cross my fingers that my checkin fixed it for everyone.  If not, please reopen and I'll see what else I can try.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
Crash Signature: [@ ReadCMAPTableFormat12]
You need to log in before you can comment on or make changes to this bug.