Closed Bug 383251 Opened 13 years ago Closed 13 years ago

Links in Add-on Manager should be handled internally

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 349309

People

(Reporter: zero_ant, Assigned: jag+mozilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070601 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070601 SeaMonkey/2.0a1pre

Currently (Build 2007060102), clicking links in the Add-on Manager window launches external application/browser if SeaMonkey is not set as default browser.

Reproducible: Always

Steps to Reproduce:
1. Open Add-on Manager
2a. Click Get Extensions/Get Themes link (at the bottom right of the window)
or
2b. Look at DOM Inspector's About page and then click Visit Home Page link
Actual Results:  
SeaMonkey requests permission to launch external application (in my case: Firefox because it is my default browser)

Expected Results:  
Links should be handled internally, except if Navigator component is not installed.
Version: unspecified → Trunk
Component: XP Apps → XP Apps: GUI Features
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349309
Status: RESOLVED → VERIFIED
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.