Last Comment Bug 383446 - upload of huge (~2GB) files through file input fails silently
: upload of huge (~2GB) files through file input fails silently
Status: RESOLVED DUPLICATE of bug 215450
:
Product: Core
Classification: Components
Component: HTML: Form Submission (show other bugs)
: unspecified
: x86 Linux
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 03:44 PDT by Javier Amor Garcia
Modified: 2009-11-15 22:38 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Javier Amor Garcia 2007-06-06 03:44:24 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-1)

When trying to submit large files using the HTML file input control, the browser simply doesn't submit any data and neither inform of any problem

Reproducible: Always

Steps to Reproduce:
1. go to any web page which has a HTML file input for upload (i have reproduced this byg with gmail attachments, for example)
2. use the file input to choose a very large file (i used a 2 Gb file)
3. click in the control to submit the form


Actual Results:  
The form wasn't submitted. There isn't any feedback to the user about what is going on

Expected Results:  
the form should be submitted with the data.
If this cannot be done, a mesage should appear explaining to the user the problem

I had tried the same operatiion with konqueror; in this browser the rssult is a program crash
Comment 1 Alexandros Vellis 2008-01-08 08:23:09 PST
Confirmed. It seems that Firefox fails silently to upload files larger than 2GB.

This shouldn't happen when the operating system Firefox runs on, as well as the receiving server system, have no such limitations. And it certainly shouldn't fail with no notification at all!


A little research reveals this page:
http://www.motobit.com/help/scptutl/pa98.htm
which describes similar limits to other browsers.

This page also reveals that funny things - *negative* Content-Length - happen when one tries to upload multiple files, with total sizes that exceed 2GB.


I'd be happy to see Firefox overcome this obstacle soon and support big file uploads.
Comment 2 Jim Michaels 2009-04-07 20:15:14 PDT
yes, the windows version has this problem too.
actually, the filesize limit is 2^32-1=2GiB-1=2147483647 I think, just like the firefox browser filesize limitation.  somebody used a 32-bit int or a long for the filesize or something like that instead of a long long (gcc) or a __int64 (MINGW, borland, MSVC++).

however, on MinGW compiler which is a gcc variant, it does not natively support __int64 so you must do something like
/*detect MinGW compiler and if it is*/
#if defined(__MINGW32__)
#include <basetsd.h> /* defines __int64.  not needed for borland, MSVC++ */
typedef __int64 qlong;
/* now define a printf format string we can use */
#define QLPRINTF "%I64d"
#elif defined(__BORLANDC__)||defined(_MSC_VER)
typedef __int64 qlong;
/* now define a printf format string we can use */
#define QLPRINTF "%I64d"
#elif defined(LINUX)
typedef long long qlong;
/* now define a printf format string we can use */
#define QLPRINTF "%lld"
#elif defined(__DJGPP__)
typedef long long qlong;
/* now define a printf format string we can use */
#define QLPRINTF "%lld"
#endif


your mileage will vary for your distribution/build of linux depending on what -D options you have on gcc/g++, it may not use LINUX #define.  check your build scripts and makefiles.
Comment 3 Makoto Kato [:m_kato] 2009-08-12 18:45:11 PDT

*** This bug has been marked as a duplicate of bug 215450 ***
Comment 4 Nissamudeen Rawther 2009-11-15 22:38:27 PST
Any update on this issue? 
With the current usage scenario, 2 GB limit is really small. Google Chrome don't have a limitation of 2GB.

Note You need to log in before you can comment on or make changes to this bug.