If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

multiple events at the same time that divide the event width cause all the events at other times of the day to be reduced in width

VERIFIED DUPLICATE of bug 304741

Status

Calendar
Calendar Views
VERIFIED DUPLICATE of bug 304741
10 years ago
10 years ago

People

(Reporter: Paul Ward, Unassigned)

Tracking

Sunbird 0.5
PowerPC
Mac OS X

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4pre) Gecko/20070529 Sunbird/0.5

If you create two events on the same day with overlapping times, the event widths in day and week view are divided between the number of events. IE two events have 1/2 half the available width, and 3 have 1/3 of the width. All good.

However, all the other events on the same day also have their widths divided by the highest multiple of events in a day. IE if 4 events overlap, then all events on that day will be 1/4 width.

The overlap event width division should only affect the area on a day where the overlap occurs.  

Reproducible: Always

Steps to Reproduce:
1. create two or more events that have a full or partial time overlap
2.
3.
Actual Results:  
all events on that day have their display width divided by the highest number of items overlapping.

Expected Results:  
It should only divide the display width of the items that overlap not all items on that day.
(Reporter)

Updated

10 years ago
Version: unspecified → Sunbird 0.5

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 304741

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.