nsSessionStore.js Error reported in error console when popup window is created

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: marc, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When clicking on the image to open a larger one, the popup opens successfully but an error is reported in the console.

The error says:

[Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIFileOutputStream.init]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///C:/Mozilla/Firefox/components/nsSessionStore.js :: sss_writeFile :: line 2025"  data: no]
file:///C:/Mozilla/Firefox/components/nsSessionStore.js
Line 2025

Reproducible: Always

Steps to Reproduce:
1. Open URL as specified
2. Click on the large image
3. ..er, that's it.
Actual Results:  
Opens window but flags up error.

Expected Results:  
Opens window.

A number of extensions are loaded, including FireBug.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch

Comment 1

12 years ago
Opening a popup should have nothing to do with writing to disk. Are you actually able to reproduce this behavior repeatedly? If so: does this happen in safe mode as well (or on a clean profile)?
Component: General → Session Restore
QA Contact: general → session.restore
(Reporter)

Comment 2

11 years ago
Not tried this in safe mode, or a new profile.  When my free time allows, I'll have a go.

But yes- this is a 100% repeatable problem.
(Reporter)

Comment 3

11 years ago
OK- it *doesn't* do this in Safe Mode, so it's an extension that's doing it.

All I need to do is disable them one by one.  *Sigh*.

Don't wait up :)

Comment 4

11 years ago
Closing as per comment #3. Please reopen in case it wasn't due to any of your extensions (once you're done disabling them).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Might be a Firebug issue.  See http://code.google.com/p/fbug/issues/detail?id=116
You need to log in before you can comment on or make changes to this bug.