Cannot send email to <postmaster>, a violation of RFC 821 and 2821

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Composition
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Nicolas Pioch, Assigned: Florian Pritz)

Tracking

Trunk
Thunderbird 3.3a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.58 KB, patch
Bienvenu
: review+
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla Thunderbird version 2.0.0.0 (20070326)

It is impossible to compose/send an email to <postmaster>,
as Mozilla Thunderbird claims this is not a valid "user@host" address.

Yet, as RFC821 or RFC 2821 paragraph 3.6 state:
http://www.ietf.org/rfc/rfc2821.txt
   -  The reserved mailbox name "postmaster" may be used in a RCPT
      command without domain qualification (see section 4.1.1.3) and
      MUST be accepted if so used.

paragraph 4.1.1.3 of RFC 2821:
4.1.1.3 RECIPIENT (RCPT)
(...)
Syntax:
   "RCPT TO:" ("<Postmaster@" domain ">" / "<Postmaster>" / Forward-Path)
                    [SP Rcpt-parameters] CRLF

Paragraph 4.5.1:
4.5.1 Minimum Implementation
   In order to make SMTP workable, the following minimum implementation
   is required for all receivers.  The following commands MUST be
   supported to conform to this specification:
(...)
   Any system that includes an SMTP server supporting mail relaying or
   delivery MUST support the reserved mailbox "postmaster" as a case-
   insensitive local name.  This postmaster address is not strictly
   necessary if the server always returns 554 on connection opening (as
   described in section 3.1).  The requirement to accept mail for
   postmaster implies that RCPT commands which specify a mailbox for
   postmaster at any of the domains for which the SMTP server provides
   mail service, as well as the special case of "RCPT TO:<Postmaster>"
   (with no domain specification), MUST be supported.

As a reminder, sending email to <postmaster> is a way to contact
the postmaster of your sending SMTP server (the postmaster of your
Mail Submission Agent).

In case someone suggests to "fix" this problem by automatically
taking the sender's domain and appending it to the postmaster@
recipient address, this is not appropriate, as these domains do not
necessarily match. Here's an example:

Let's suppose I send email using "foo@example.com" in the "From"
field, but I use smtp.google.com as outgoing mail server.

Sending email to <postmaster> is supposed (as per the RFC) to
allow me to request my Mail Submission provider's help (Google Postmaster)
in case I encounter delivery issues, such as a remote server
blacklisting emails sent from Google's outbound MTAs.

Auto-modification by the MUA of <postmaster> to add the domain would
result in sending email to <postmaster@example.com> which is not
appropriate as this postmaster is not involved in the mail delivery path.

So people should really (per SMTP RFC) be able to send email to <postmaster>
to report problems and request assistance.


Reproducible: Always

Steps to Reproduce:
1. Open new mail compose window by clicking the "WRITE" button in the 3pane toolbar
2. in the compose window, on the "To:" field, type: "<postmaster>" without the double quotes
3. put "test" in the Subject: field and in the body of the email
4. Hit the send button
Actual Results:  
A popup appears reading:
"Send Message: postmaster is not a valid e-mail address because it is not
of the form user@host. You must correct it before sending the e-mail."

Expected Results:  
Mail should have been sent.

Comment 1

10 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
Version: unspecified → 2.0
(Assignee)

Comment 2

7 years ago
Still not fixed in 3.1.4.

What's the status of this bug?
(Assignee)

Comment 3

7 years ago
Created attachment 479406 [details] [diff] [review]
Bugfix patch
Attachment #479406 - Flags: superreview?(bugzilla)
Attachment #479406 - Flags: review?(bienvenu)
Assignee: nobody → bluewind
Status: NEW → ASSIGNED
Version: 2.0 → Trunk
Comment on attachment 479406 [details] [diff] [review]
Bugfix patch

This doesn't need sr, although Neil should review the suite/ part.
Attachment #479406 - Flags: superreview?(bugzilla) → review?(neil)
Component: Message Compose Window → Composition
Product: Thunderbird → MailNews Core
QA Contact: message-compose → composition

Comment 5

7 years ago
Comment on attachment 479406 [details] [diff] [review]
Bugfix patch

should wrap those long lines, but other than that, works fine, thx for the patch.
Attachment #479406 - Flags: review?(bienvenu) → review+

Updated

7 years ago
Attachment #479406 - Flags: review?(neil) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/bcdc4a564b1e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
You need to log in before you can comment on or make changes to this bug.