Last Comment Bug 383759 - Focus event inconsistent for search box autocomplete
: Focus event inconsistent for search box autocomplete
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla10
Assigned To: alexander :surkov
:
:
Mentors:
Depends on: 673958
Blocks: focuseventa11y
  Show dependency treegraph
 
Reported: 2007-06-08 11:06 PDT by Scott Haeger
Modified: 2011-09-29 08:14 PDT (History)
4 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Scott Haeger 2007-06-08 11:06:52 PDT
I see the following focus events (state-change:focus not looked at) when going from the the first list item back to the entry in the toolbar search box:

focus(0, 0, None)
        source: [autocomplete | Search]
        application: [application | Minefield]
focus(0, 0, None)
        source: [entry | ]
        application: [application | Minefield]
focus(0, 0, None)
        source: [tree table | ]
        application: [application | Minefield]

Strangely enough, the focus events are correct for the same operation in in-page autocomplete boxes, but their structures appear to be different.  I would expect to see a focus event only on the end target.  What this would be in this case is up for argument.  I would say the tree table because the in-page case gives a focus on a tree (not tree table as seen in search box).
Comment 1 Scott Haeger 2007-06-08 11:07:59 PDT
This bug original came from work done on this bug https://bugzilla.mozilla.org/show_bug.cgi?id=381433
Comment 2 Evan Yan 2007-06-11 05:31:31 PDT
(In reply to comment #1)
> This bug original came from work done on this bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=381433
> 
The bug was there before work done on bug 381433, so not a regression of bug 381433.
Comment 3 David Bolter [:davidb] 2009-06-16 11:51:22 PDT
Mass un-assigning bugs assigned to Aaron.
Comment 4 alexander :surkov 2011-03-10 05:18:38 PST
Fernando, is this bug valid?
Comment 5 alexander :surkov 2011-09-28 02:19:13 PDT
fixed by bug 673958
Comment 6 Marco Zehe (:MarcoZ) 2011-09-29 08:14:35 PDT
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.