use fixed spelling languages depending on domain

RESOLVED DUPLICATE of bug 360668

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 360668
11 years ago
7 years ago

People

(Reporter: ludo.aelbrecht+mozilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Hi,
I love the spelling checker that's recently been introduced in Firefox. One thing that's bothering me though, is that I'm constantly changing the language, depending on the forum/webmail/whatever I'm visiting.
It'd be great if I could say: "Remember I want English for the bugzilla.mozilla.org domain." (It would really need to be subdomain-based, e.g. for en.wikipedia vs nl.wikipedia)

Interface-wise, it'd just need an extra item in the "Languages" context menu (i.e. "remember" if there's no association yet, and "forget" if there already is one).
Implementation-wise, maybe all that's needed is a text file containing subdomains & languages?
Maybe I'm dreaming, but it'd be cool if this got into FF3.0. Well if it got into FF3.x I'd very happy as well :)

It would _really_ save me (and most non-english people, I guess) a lot of time. 

Thanks,
Ludo

Reproducible: Always

Comment 1

11 years ago
see bug 360668 + bug 338427

extension : https://addons.mozilla.org/en-US/firefox/addon/3414 . It uses auto-detection, but it also remembers the dictionar per site.
(Reporter)

Comment 2

11 years ago
Thanks Jo. Sorry I filed a dupe :o
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360668

Comment 3

7 years ago
Check this for checking several languages simultaneously
https://bugzilla.mozilla.org/show_bug.cgi?id=660506

Comment 4

7 years ago
Check this for checking several languages simultaneously
https://bugzilla.mozilla.org/show_bug.cgi?id=660506
You need to log in before you can comment on or make changes to this bug.