Closed Bug 384083 Opened 15 years ago Closed 15 years ago

Profile migrator is broken when first profile is from NS4

Categories

(SeaMonkey :: Startup & Profiles, defect)

x86
Windows XP
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: bugzilla)

References

()

Details

Attachments

(1 file)

For a description of the problem have a look at http://groups.google.de/group/mozilla.dev.apps.seamonkey/browse_thread/thread/baffdffee338b3d1/201767b0eda5bc5b

char migratedStr[3] in Line 522 is set to "no" in the first loop and stays "no" for the other loops, although it's a local variable (perhaps caused by an optimization of the compiler). Setting it to 0 after declaration fixes the problem and the migrator works.
Attachment #268013 - Flags: review?(neil)
I also tested my old registry.dat with 4 profiles and the NS test profile and I can choose between those 4 profiles at migration.
FYI.
Bug 379068 is already applied to trunk.
> Bug 379068 – Remove support for Netscape 4.x migration from the trunk
(In reply to comment #3)
> FYI.
> Bug 379068 is already applied to trunk.
> > Bug 379068 – Remove support for Netscape 4.x migration from the trunk

Yes, but we're not trying to migrate Netscape 4.x profiles with this bug. The problem is when a registry file references old Netscape 4.x profiles directly (which weren't migrated) the migrator tries to skip them and ends up skipping the rest of the good profiles as well.
Attachment #268013 - Flags: review?(neil) → review+
I checked this in earlier.

Thanks for spending the time looking into this Bruno and doing the patch.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.