Context menus should not eat clicks

VERIFIED DUPLICATE of bug 21390

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 21390
18 years ago
10 years ago

People

(Reporter: Blake Ross, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000059698

I think I saw this reported awhile back, please mark as dup if you find it.

Context menus are eating any clicks outside their area that are used to dismiss 
them; they shouldn't be.  As an example, right clicking page text to bring up 
the context menu and then left-clicking on an HTML textbox (to dismiss it) 
should not only dismiss the context menu, it should set focus to the textbox 
(which inconveniently requires two clicks at the moment).

Comment 1

18 years ago
Yes, this issue is already the subject of bug 21390, "Clicking on Widget or 
link does nothing if menu open" -- context menus included.

*** This bug has been marked as a duplicate of 21390 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
vrfy
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.