Opening blank tab enough to cause document leak

VERIFIED FIXED

Status

()

Toolkit
Safe Browsing
--
critical
VERIFIED FIXED
11 years ago
4 years ago

People

(Reporter: tor, Unassigned)

Tracking

({mlk})

Trunk
x86
Linux
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Steps to reproduce
------------------

  * set firefox start page to "blank page"
  * quit firefox
  * set up leak logging (XPCOM_MEM_LEAK_LOG, leak-gauge setup, etc)
  * start firefox
  * press ^T (new tab)
  * quit firefox

Results
-------

Two nsHTMLDocument objects (amongst others) leaked according to XPCOM_MEM_LEAK_LOG.

leak-gauge output:

Leaked 2 out of 9 DOM Windows
Leaked 29 out of 40 documents
Leaked 0 out of 4 docshells
Does it still happen if you move aside the safe browsing JS components (nsSafeBrowsing*, nsUrlClassifier*)?
(Reporter)

Comment 2

11 years ago
No leaks if those are moved aside:

Leaked 0 out of 9 DOM Windows
Leaked 0 out of 40 documents
Leaked 0 out of 4 docshells

Updated

11 years ago
Depends on: 383269
This is making any leak debugging very hard since it's very easy to run into this leak which swamps any other leaks.
Severity: normal → critical
Component: Layout → Phishing Protection
Product: Core → Firefox
QA Contact: layout → phishing.protection
Flags: blocking-firefox3?

Comment 4

11 years ago
Jonas, Brendan is supposedly working on this in bug 383269.
(Reporter)

Comment 5

11 years ago
The checkin for bug 383269 appears to have fixed this particular leak.

Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Still fixed after the second patch there, right?
(Reporter)

Comment 7

11 years ago
Yes.
verified fixed using Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3pre) Gecko/2008010710 Minefield/3.0b3pre 
nsStringStats
 => mAllocCount:          16225
 => mReallocCount:         3692
 => mFreeCount:           16225
 => mShareCount:          15617
 => mAdoptCount:           2037
 => mAdoptFreeCount:       2037

no leak -> Verified fixed
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.