Last Comment Bug 384395 - monospace font shouldn't use ligatures
: monospace font shouldn't use ligatures
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 00:12 PDT by Mike Beltzner [:beltzner, not reading bugmail]
Modified: 2007-09-04 15:03 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
example of "f i fi" in ProFont, a monospace font (6.37 KB, image/png)
2007-06-14 00:13 PDT, Mike Beltzner [:beltzner, not reading bugmail]
no flags Details

Description Mike Beltzner [:beltzner, not reading bugmail] 2007-06-14 00:12:23 PDT
Using ProFont (http://www.tobias-jung.de/seekingprofont/) on OSX/Intel, typing "fi" results in the creation of a ligature that takes one character width. See attached screenshot.
Comment 1 Mike Beltzner [:beltzner, not reading bugmail] 2007-06-14 00:13:29 PDT
Created attachment 268325 [details]
example of "f i fi" in ProFont, a monospace font
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2007-06-14 00:16:20 PDT
I think that monospace fonts should not have ligatures...
Comment 3 Simon Montagu :smontagu 2007-06-14 01:01:09 PDT
In Latin script, I agree that monospace fonts should not have ligatures. In Indic and Arabic scripts, I'm not so sure. Maybe each cluster should occupy one character-cell, but maybe life isn't that simple.
Comment 4 fantasai 2007-06-14 06:37:08 PDT
The ligature must be provided by the font, yes? Unless we're generating the ligature somehow, this is a bug in the font, not in our font-rendering.
Comment 5 Behdad Esfahbod 2007-06-14 06:45:07 PDT
I'm of the opinion that this is a font issue too.
Comment 6 Johnathan Nightingale [:johnath] 2007-06-28 11:29:52 PDT
Possibly related (since I also use Profont for monospace) is that some character combinations, like lower-case-L, followed by forward slash:

l/

simply disappear.  

These behaviours (the f-i ligature and the disappearing l-/) are not seen in Safari 3 beta using the same font + size, so if it is a font issue, Safari must be dealing with it differently than we are.
Comment 7 Stuart Parmenter 2007-06-28 11:40:17 PDT
Safari doesn't support ligatures or kerning, so you wouldn't see it there.
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2007-06-28 15:44:01 PDT
How many of these broken fonts are there? We could work around this fairly easily, at least on Mac.
Comment 9 Johnathan Nightingale [:johnath] 2007-06-28 18:20:18 PDT
Given Pav's point in comment 7, this may really be a profont only problem.  Part of the reason there are multiple people encountering it is that profont is a popular geek font for displaying monospace text legibly at small point sizes, as a way to fit more into a given space.  

Obviously we shouldn't work around a profont specific issue, but I don't know how widespread it is.  I certainly haven't seen the behaviour using the default monospace fonts on either mac or windows.
Comment 10 Jesse Ruderman 2007-09-04 11:00:56 PDT
http://www.google.com/search?q=profont+ligatures reveals that Firefox trunk isn't the application that has trouble due to ligatures in profont.
Comment 11 Vladimir Vukicevic [:vlad] [:vladv] 2007-09-04 15:03:21 PDT
Yeah, ProFont.  We can't really do anything about it -- the underlying text system is doing the ligaturization, not us.  Use ProFontX.

Note You need to log in before you can comment on or make changes to this bug.