Last Comment Bug 384501 - If you have a port name in the urlbase, SMTP may not work
: If you have a port name in the urlbase, SMTP may not work
Status: RESOLVED FIXED
:
Product: Bugzilla
Classification: Server Software
Component: Email Notifications (show other bugs)
: 3.0
: All All
: -- normal (vote)
: Bugzilla 3.0
Assigned To: Max Kanat-Alexander
: default-qa
:
Mentors:
: 372668 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 16:09 PDT by Max Kanat-Alexander
Modified: 2007-06-15 15:41 PDT (History)
1 user (show)
LpSolit: approval+
LpSolit: approval3.0+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (696 bytes, patch)
2007-06-14 16:15 PDT, Max Kanat-Alexander
LpSolit: review+
Details | Diff | Splinter Review

Description Max Kanat-Alexander 2007-06-14 16:09:33 PDT
If your urlbase is something like:

 http://hostname:8080/

then Bugzilla tries to do this when it connects to SMTP:

  EHLO hostname:8080

But that's not right! It should just do EHLO hostname.
Comment 1 Max Kanat-Alexander 2007-06-14 16:15:37 PDT
Created attachment 268433 [details] [diff] [review]
v1

This fixes it, as tested.
Comment 2 victory <never@receive.bug.mails.i.hate.spammer> 2007-06-14 17:10:59 PDT
*** Bug 372668 has been marked as a duplicate of this bug. ***
Comment 3 Frédéric Buclin 2007-06-15 10:39:29 PDT
Comment on attachment 268433 [details] [diff] [review]
v1

This fix was already suggested in bug 372668 comment 3.
Comment 4 Max Kanat-Alexander 2007-06-15 15:41:08 PDT
tip:

Checking in Bugzilla/Mailer.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Mailer.pm,v  <--  Mailer.pm
new revision: 1.9; previous revision: 1.8
done

3.0:

Checking in Bugzilla/Mailer.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Mailer.pm,v  <--  Mailer.pm
new revision: 1.7.2.2; previous revision: 1.7.2.1
done

Note You need to log in before you can comment on or make changes to this bug.