Request to customize the lifecycle of a bug (for multiple retest stage)

RESOLVED DUPLICATE of bug 101179

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 101179
11 years ago
11 years ago

People

(Reporter: chang, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: Bugzilla 3.0

Question.

In my current project, there are 3 Verification steps before we can close the bug.

Test Environment:
There are 3 test environments for testing
1.	System Test (offshore test team)
2.	System Integration Test - SIT (local test team)
3.	User Acceptance Test – UAT (client test team)

Example:
1.	When a bug is detected during UAT, a bug shall be reported
2.	It will be investigated, fixed and released to System Test for 1st level of testing. STATUS is “Pending to Retest in ST”
3.	if this pass, it the STATUS is “Pending release to SIT”
4.	After release, it will be retested again and STATUS is “Pending to Retest in SIT”
5.	if this pass, it the STATUS is “Pending release to UAT”
6.	After release, it will be retested again and STATUS is “Pending to Retest in UAT”


Can the “STATUS” field and the workflow be configurable to adopt such process above? This is a standard process many enterprise testing phase to have multiple release/retest stage on different environment

Appreciate your feedback.

Feel free to contact me (cheokweng.chang@logicacmg.com) if you need further clarifications.

Thanks

Cheok Weng

Reference: 

http://www.bugzilla.org/docs/tip/html/lifecycle.html
5.4. Life Cycle of a Bug
The life cycle, also known as work flow, of a bug is currently hardcoded into Bugzilla. Figure 5-1 contains a graphical representation of this life cycle. If you wish to customize this image for your site, the diagram file is available in Dia's native XML format. 
Figure 5-1. Lifecycle of a Bugzilla Bug


Reproducible: Always

Steps to Reproduce:
1.Not applicable
2.
3.
Actual Results:  
Not applicable

Expected Results:  
Not applicable

Not applicable
(Reporter)

Comment 1

11 years ago
Created attachment 268468 [details]
Info on the customization/enhancement
Attachment #268468 - Flags: review?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 101179

Updated

11 years ago
Attachment #268468 - Flags: review?
You need to log in before you can comment on or make changes to this bug.