Absolute Positioning grabber (mGrabber) hidden and inaccesible

RESOLVED FIXED

Status

SeaMonkey
Composer
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Art Skiles, Assigned: Art Skiles)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

886 bytes, patch
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070615 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070615 SeaMonkey/2.0a1pre

The "grabber" becomes hidden behind other page elements during editing. Shouldn't the grabbers z-index be maxed out in EditorOverride.css or /mozilla/editor/libeditor/htmlnsHTMLAbsPosition.cpp ( RefreshGrabber() )?

Reproducible: Always

Steps to Reproduce:
1.Select and move an absolutely positioned element.
2.Release over an element with a higher z-index.
3.
Actual Results:  
grabber border remains but crosshairs gone and can't move.

Expected Results:  
grabber remains visible at all times. (z-index should be maxed)

Comment 1

10 years ago
Your URL don't work. Site temporarily closed. Can you retest with latest builds ?
(Assignee)

Comment 2

10 years ago
Still happens in the following build:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

Hopefully you didn't mean the latest nightly build.

To reproduce:

1) Select or create a div from text off the default seamonkey startup page and select layer button (make it pos abs).

2) Grab layer and move atop seamonkey logo at top of page.

3) Grabber becomes covered.

Again, this seems like an easy fix by maxing out the grabber z-index.

Comment 3

10 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

10 years ago
Created attachment 317368 [details] [diff] [review]
Sets z-index of the mozGrabber.

Possible patch for "grabber disappearing".
Attachment #317368 - Flags: review?(reed)
Comment on attachment 317368 [details] [diff] [review]
Sets z-index of the mozGrabber.

I'm not a valid reviewer for this code. Maybe try daniel@glazman.org instead?
Attachment #317368 - Flags: review?(reed)
(Assignee)

Updated

10 years ago
Attachment #317368 - Flags: review?(daniel)
Comment on attachment 317368 [details] [diff] [review]
Sets z-index of the mozGrabber.

r=daniel@glazman.org
go ahead
Attachment #317368 - Flags: review?(daniel) → review+
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
The bug isn't resolved until the patch has been landed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: composer → amidude99
Status: REOPENED → NEW
QA Contact: composer
Comment on attachment 317368 [details] [diff] [review]
Sets z-index of the mozGrabber.

I believe this needs SR, too.
Attachment #317368 - Flags: superreview?(neil)
Keywords: checkin-needed

Comment 9

10 years ago
Comment on attachment 317368 [details] [diff] [review]
Sets z-index of the mozGrabber.

>+  z-index: 2147483646;
> }
>
> /* INLINE TABLE EDITING */
>
> a[\_moz_anonclass="mozTableAddColumnBefore"] {
>   position: absolute;
>   z-index: 2147483647; /* max value for this property */
Though I guess copying this line would be just that little bit better still!
Attachment #317368 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 10

10 years ago
Created attachment 318143 [details] [diff] [review]
Max out grabber z-index.

Bumped up to max z-index value.
Attachment #317368 - Attachment is obsolete: true
Attachment #318143 - Flags: superreview?(neil)
Attachment #318143 - Flags: review?(daniel)

Updated

10 years ago
Attachment #318143 - Flags: superreview?(neil) → superreview+
(Assignee)

Updated

10 years ago
Attachment #318143 - Flags: review?(daniel)
(Assignee)

Comment 11

10 years ago
Going ahead with checkin-needed since we have superreview+.
Keywords: checkin-needed
Checking in editor/composer/src/res/EditorOverride.css;
/cvsroot/mozilla/editor/composer/src/res/EditorOverride.css,v  <--  EditorOverride.css
new revision: 1.41; previous revision: 1.40
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Summary: Absolute Positioning grabber (mGrabber) hidden and inaccesible. → Absolute Positioning grabber (mGrabber) hidden and inaccesible
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.