Bidi text causes improper rendering of borders in links

RESOLVED DUPLICATE of bug 337274

Status

()

RESOLVED DUPLICATE of bug 337274
12 years ago
11 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070617 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5) Gecko/20070606 GranParadiso/3.0a5

See the attached test case.  Try to activate the four link using either mouse or tab.  The border for the first three links is rendered improperly, by rendering a border on the inner text with different direction.  The only difference between the first two links and the last two links is that the text in one of them is in Persian, which is a right-to-left language.

Happens both in FF3.0a5 and on the trunk.

Reproducible: Always

Steps to Reproduce:
1. Load the attached test case.
2. For each of the four links, activate it either using mouse or keyboard.  Watch the borders rendered improperly for all except the last link.
Actual Results:  
Borders are drawn for the inner span of text.

Expected Results:  
Only one set of border must be drawn for the whole link.

about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=beta --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-default-toolkit=cairo-windows --enable-update-packaging --with-branding=browser/branding/unofficial
Component: GFX → Layout: Block and Inline
QA Contact: general → layout.block-and-inline
(Reporter)

Comment 1

12 years ago
Created attachment 268709 [details]
Testcase

The test case for the bug.
(Reporter)

Updated

12 years ago
Keywords: regression
Version: unspecified → Trunk

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337274
You need to log in before you can comment on or make changes to this bug.