Last Comment Bug 384850 - Thunderbird crashes when Lightning and Funambol PlugIn 0.3.1 are installed [@ nsACString_internal::IsVoid]
: Thunderbird crashes when Lightning and Funambol PlugIn 0.3.1 are installed [@...
Status: VERIFIED INVALID
FIX: update to Funambol PIM Plugin v0...
:
Product: Calendar
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 386246 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 23:51 PDT by Guido
Modified: 2008-02-21 01:41 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Guido 2007-06-17 23:51:09 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 2007061403

I have Thunderbird 2.0.0.4 (Build 20070604) on Windows XP (Build 2600.xpsp_sp2_gdr.020227-2254) and have tried to install Lightning 0.5RC2. I had already the latest Funambol Plugin installed  (http://sourceforge.net/project/showfiles.php?group_id=149326). After installing Lightning 0.5RC2 it was not possible to start Thunderbird anymore. Thunderbird crashes every time at startup. The only way to get a working Thunderbird was to delete manually either the directory for the lightning extension or the directory for the Funambol extension. 

If i try to start Thunderbird with both extension, then i can see Thunderbird for 2 seconds in the task manager, but nothing apperas on the screen. I don't see an error message. There is only a "Dr. Watson" message in the windows application error log: 

==========================================================
Die Anwendung "C:\Programme\Kommunikation\Thunderbird_2.0\thunderbird.exe" hat einen Programmfehler verursacht. Datum und Zeit des Fehlers: 18.06.2007 um 08:23:44.052 Ausnahme: c0000005 an Adresse 6038F615 (xpcom_core!nsACString_internal__IsVoid)
==========================================================

Maybe the reason for this problem is Funambol and not Lightning, but there should be at least a note for this serious problem in the release notes?




Reproducible: Always

Steps to Reproduce:
see Details
Comment 1 Guido 2007-06-18 00:13:33 PDT
One additional information (maybe helpful): Until today i have used a 0.5 pre version of Lightning from march (I don't remember exactly which build). There was no problem with Lightning und the Funambol extension. It was possible to sync the Lightning calendar and Thunderbird adressbook against a Funambol server and then i could sync my nokia e70 against the Funambol server (I've used mobical.net)
Comment 2 Daniel Boelzle [:dbo] 2007-06-18 01:01:04 PDT
I can confirm that the Funambol plugin 0.3.1 crashes with 0.5 RC2. The Funambol guys have uploaded a version 0.3.2 for calendar 0.5, please have a look at <http://sourceforge.net/forum/forum.php?forum_id=703483>.
That plugin works for me with 0.5 RC2, although I haven't tried to sync, but everything starts up properly. Please reopen if plugin 0.3.2 still crashes your tbird.
Comment 3 Stefan Sitter 2007-06-18 10:51:31 PDT
Verified on Windows 2000 too.

Thunderbird 2.0.0.4 + Lightning 0.5 RC2 + Funambol 0.3.1 -> Crash
Thunderbird 2.0.0.4 + Lightning 0.5 RC2 + Funambol 0.3.2 -> No Crash

Just for reference in case someone reports the same issue again:
Stack Trace for Talkback Incident ID TB33241124Y

nsACString_internal::IsVoid  
    [mozilla/xpcom/string/src/nsTAString.cpp, line 150]
nsXPCWrappedJSClass::CallMethod  
    [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1300]
nsXPCWrappedJS::CallMethod  
    [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
SharedStub  
    [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
FunambolCom.dll + 0x22d0 (0x022b22d0)
FunambolCom.dll + 0x1218 (0x022b1218)
XPTC_InvokeByIndex  
    [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  
    [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2169]
XPC_WN_CallMethod  
    [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1455]
js_Invoke  
    [mozilla/js/src/jsinterp.c, line 1375]
js_Interpret  
    [mozilla/js/src/jsinterp.c, line 3944]
js_Execute  
    [mozilla/js/src/jsinterp.c, line 1634]
JS_ExecuteScript  
    [mozilla/js/src/jsapi.c, line 4188]
nsXULDocument::ExecuteScript  
    [mozilla/content/xul/document/src/nsXULDocument.cpp, line 3699]
nsXULDocument::OnStreamComplete  
    [mozilla/content/xul/document/src/nsXULDocument.cpp, line 3615]
nsStreamLoader::OnStopRequest  
    [mozilla/netwerk/base/src/nsStreamLoader.cpp, line 137]
nsJARChannel::OnStopRequest  
    [mozilla/modules/libjar/nsJARChannel.cpp, line 712]
Comment 4 Stefan Sitter 2007-06-28 14:22:27 PDT
*** Bug 386246 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Sitter 2007-06-29 03:07:49 PDT
*** Bug 386246 has been marked as a duplicate of this bug. ***
Comment 6 Stefan Sitter 2007-07-04 02:55:34 PDT
Simon, I'd like you to add this to the Lightning 0.5 Known Issue page.
Comment 7 Simon Paquet [:sipaq] 2007-07-04 03:12:22 PDT
(In reply to comment #6)
> Simon, I'd like you to add this to the Lightning 0.5 Known Issue page.

Done.


Note You need to log in before you can comment on or make changes to this bug.