Closed Bug 38505 Opened 25 years ago Closed 3 months ago

XPInstall progress dialog should be sizeable, minimizable

Categories

(Core Graveyard :: Installer: XPInstall Engine, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED INCOMPLETE
Future

People

(Reporter: timeless, Assigned: slogan)

References

Details

(Keywords: helpwanted)

Attachments

(1 file)

2000050715
I think dialog should be able to be minimized.  Personally I'd also like to be 
able to make it larger [maximizing this dialog is not required].

Maybe a checkbox "play alert when done"
Nothing to do with this component, but dup anyways

*** This bug has been marked as a duplicate of 26029 ***
Status: NEW → RESOLVED
Closed: 25 years ago
Resolution: --- → DUPLICATE
No. Wrong event/item
<BenGoodger> timeless: reopen ... it is different ... this is the dlg that 
downloads bits of the app ...

Yes it's true the save as dialog has nothing to do with this component, but 
this component does have a progress dialog
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
timeless@bemail.org,
can you provide us a screen shot, so we know what you're talking about?
thanks!
cathleen
Attached image The problem dialog
Parcelling out Cathleen's bugs
Assignee: cathleen → dbragg
Status: REOPENED → NEW
Sorry timeless, you're right -- that's a completely different download dialog, 
and this IS the correct component.  I didn't realize that earlier.  

dbragg, where do we set the minimizable and resizable flags?
Status: NEW → ASSIGNED
Whiteboard: [nsbeta3-]
Adding nsbeta3 keyword to bugs which already have nsbeta3 status markings so 
the queries don't get all screwed up.
Keywords: nsbeta3
It's now resizable as is the Confirm dialog.  It's not minimizable though.
Not being able to minimize download/progress windows is bug 26029.  I don't 
think being able to resize the dialog is important (since you can now scroll 
through the url being downloaded or copy it to a text editor), but this isn't 
my bug so I won't mark it as a dup yet.
Sorry, missed comments earlier in the bug.
Summary: Win32 Progress dialog should be sizeable minimizable → Win32 installer progress dialog should be sizeable, minimizable
Similar bug 26029 is marked a nsbeta1 stopper, so I suppose this one should be
as well. The sizeable part is taken care of. According to bug 26029 they might
need a new xptoolkit feature so keep an eye on that bug to see what they do in
that other dialog.
Depends on: 26029
Keywords: nsbeta3nsbeta1
OS: Windows 2000 → All
Hardware: PC → All
Summary: Win32 installer progress dialog should be sizeable, minimizable → XPInstall progress dialog should be sizeable, minimizable
Whiteboard: [nsbeta3-]
Don has moved to another group. Install bugs -> syd
Assignee: dbragg → syd
Status: ASSIGNED → NEW
*** Bug 73647 has been marked as a duplicate of this bug. ***
Keywords: nsbeta1-
Target Milestone: --- → M1
Target Milestone: M1 → Future
QA Contact: jimmykenlee → xpi-engine
Product: Core → Core Graveyard
Status: NEW → RESOLVED
Closed: 25 years ago3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: