I think this is still is bug 354585 but they say existing problem could be new bug caused by the fix

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: siamaketezadi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Some of fonts use to be replaced with "?". Now no more "?" but wrong type of letter size/and spacing is off. my last comment for bug 354585 has three attachments which Identify and clearify this problem. This issue is going on for more that 6months. I have started to use Safari for my Persian and FF for others.

Reproducible: Always

Steps to Reproduce:
1.Just open any sites that has persian fonts. I did not check Arabic.
2.
3.
Actual Results:  
Spacing horizontally and vertically off. In persian some letters have different shape depending on where in word located. this start to occur after fix for the bug 354585 where "?" use to be placed in lieu of some of the fonts

Comment 1

12 years ago
The reason that bug 354585 was resolved as WORKSFORME is because the issue is supposed to be fixed on trunk builds.

Can you reproduce this issue on trunk? http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
You'll probably want to test with a new profile: http://kb.mozillazine.org/Profile
(Reporter)

Comment 2

12 years ago
I have included three attachements in my last respond for the bug 354585. comment #39 please compare the last three attachments in that tread. In persian like Arabic letters take different form depending where the letters located in the word. These rules as well as spacing is off in new nightly build.

Comment 3

12 years ago
Yes, but using what build? I wouldn't expect anything to change if you were using a branch build. You need to test on the trunk build that I linked.
(Reporter)

Comment 4

12 years ago
I run on latest link on comment#1 you provided same problem as stated above in comment #2
This is a mass search for bugs that are in the Firefox General component, are UNCO, and have not been changed for 1000 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the bug, please update this bug. If the issue is gone, please set the resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Updated

8 years ago
Resolution: INCOMPLETE → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.