bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Vertical scrollbar is rendered with horizontal white bars when the page is scrolled

RESOLVED WONTFIX

Status

Core Graveyard
GFX
RESOLVED WONTFIX
11 years ago
4 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070622 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5) Gecko/20070606 GranParadiso/3.0a5

Vertical scrollbars are rendered with horizontal white bars when the page containing them is scrolled vertically.  This happens all the time, no matter how the page is scrolled (PgUp/PgDn, mouse wheel, Up/Down arrow keys).

The problem seems to be related to the speed of scrolling, in that the faster the page gets scrolled, the less lines appear on the scrollbar.  Scrolling using the autoscroll (by pressing the middle mouse button) can even produce a white scrollbar!  Repeatable scrolls generate identical white lines in identical positions.

This happens both in Firefox 3.0a5 and trunk builds.

I'll be attaching screenshots shortly.

Reproducible: Always

Steps to Reproduce:
1. Go to <https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&format=guided>.
2. Scroll the page vertically.
3. See the white lines appear on the iframe's vertical scrollbar.
Actual Results:  
The scrollbar is rendered with white lines.

Expected Results:  
No lines should appear on the scrollbar.

about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=beta --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-default-toolkit=cairo-windows --enable-update-packaging --with-branding=browser/branding/unofficial
(Reporter)

Comment 1

11 years ago
Created attachment 269372 [details]
Screenshot #1 (scrolled using Page Down)
(Reporter)

Comment 2

11 years ago
Created attachment 269373 [details]
Screenshot #2 (scrolled using arrow keys)
(Reporter)

Comment 3

11 years ago
Created attachment 269374 [details]
Screenshot #3 (scrolled using autoscroll)
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
This is bug 381250 I think.
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> This is bug 381250 I think.
> 

I don't think so, because:

1) I can't seem to reproduce bug 381250 even though I see the current bug.
2) Bug 381250 is caused by scrolling an scrollbar itself, while this bug happens when scrolling content which itself contains a scrollbar.
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.