Closed Bug 385513 Opened 13 years ago Closed 6 years ago

Bring back the old-school Mozilla t-shirts

Categories

(Websites :: store.mozilla.org, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Gijs, Assigned: jslater)

Details

Summary says it all, really. What happened to the good old shirts? An ex-netscape employee told me ages ago there were only a few left, and they weren't for sale. Is there any chance of them making a comeback to the Mozilla Store? That'd be awesome. Also see some of the comments on http://weblogs.mozillazine.org/marcia/archives/009794.html
Which shirts did you have in mind specifically? Because although I only showed the new ones in that picture, we'll still be keeping several old favorites - mainly just variations of the logo on the front of a t-shirt. Pretty basic stuff.
I meant the really really old school "hack" shirts, (mostly?) pre-Firefox. CC-ing marcia who probably knows more about them than I do. I tried to find pictures online but failed. :-(
I think Gijs is referring to the real old Mozilla t-shirts, like a reissue of the original "Hack" shirt or the Mozilla "star" shirt that was offered a few years ago. 

John: as our resident Netscape historian, Marcia should be able to provide historical background on what's been done in the past. Asa too when he gets back.
http://geekt.org/geekt/morenews.cgi?section=11 also has some images of several different shirts.
Last time this issue was raised there was general sentiment against it here, for a few reasons, including the muddiness of who owns the original artwork. There also seems to be a sentiment against any of the more "communist" style themes that appeared on the mozilla shirts of yore. A while back Asa and I discussed having a mozilla classic line that would be a modified version of the old school stuff.

Having said that, there is a cool factor to those shirts, and I am sure if something was "hacked up" it would probably do well. But of course I am old school in that regard. Gijs: I have one old school Mozilla shirt that is hanging on the wall at Mozilla, if you really want it is yours...

(In reply to comment #4)
> I think Gijs is referring to the real old Mozilla t-shirts, like a reissue of
> the original "Hack" shirt or the Mozilla "star" shirt that was offered a few
> years ago. 
> 
> John: as our resident Netscape historian, Marcia should be able to provide
> historical background on what's been done in the past. Asa too when he gets
> back.
> 

(In reply to comment #7)
> Last time this issue was raised there was general sentiment against it here,
> for a few reasons, including the muddiness of who owns the original artwork.
> There also seems to be a sentiment against any of the more "communist" style
> themes that appeared on the mozilla shirts of yore. A while back Asa and I
> discussed having a mozilla classic line that would be a modified version of the
> old school stuff.
> 
> Having said that, there is a cool factor to those shirts, and I am sure if
> something was "hacked up" it would probably do well. But of course I am old
> school in that regard. Gijs: I have one old school Mozilla shirt that is
> hanging on the wall at Mozilla, if you really want it is yours...
> <snip>

Oh dear, that's a very tempting offer, Marcia - but if there's only one shirt left it's much better off hanging at Mozilla offices, I think (maybe add a photo of it to the Mozilla Digital Memory Bank project or something?). Plus, I'd feel guilty about all the other people who undoubtedly would like their own share of old-school Mozilla shirts. :-)

I absolutely suck at graphics design, so I don't think I'm any help here - but if we could "hack something up" then that would be awesome!
Thanks to everyone for the great feedback. Personally, I think the old school Hack shirts are pretty awesome. Marcia brings up a good point that there was a bit of a backlash from  certain areas (mainly ex-Soviet bloc) over the communist imagery...that's why we've shied away from that stuff in recent years.

I think the best thing to do might be to hold off for right now and then we can bring it up again in the fall when we add more shirts to the store (1st batch goes live in August, another batch after that later in the fall) and maybe figure out a way to do it in a manner that doesn't ruffle too many feathers.

Thanks for sharing the old school links, too - some great stuff in there.

John
Component: Mozilla Store → store.mozilla.org
Product: mozilla.org → Websites
QA Contact: jslater → store-mozilla-org
Version: other → unspecified
I want one too. :)

I'd put http://juice.box.sk/upload/00000721.jpg covering the back and either
"mozilla.org" in Revolution or the the official mozilla.org logo small on the
front where the front pocket would normally go. I think that would be cool:
classy and professional on the front and old school Mozilla culture on the
back.
So this lost out against the plush toy in the poll, I think - does that mean this is WONTFIX, or just that it'll take longer? :-)
Just that it'll take longer...it's definitely still towards the top of our list of things we want to do in the store.
I wanted to post an update about new Mozilla shirts.  One new Mozilla shirt that is heavily influenced by the old Hack shirt (there are stars, there is a dino-head and there is a freedom related tag line) is now on the store at

http://store.mozilla.org/product.php?code=14%2013113&catid=9

There is also another new Mozilla shirt in the works that is also influenced by the Hack shirt (there is a star, there is a dino-head, the colors are white, red and orange).  More news on this shirt should be available soon.

I know that neither one of this is a reprint of the Hack shirt, but personally I think having new Mozilla shirts that are influenced by that old design is the best thing to do for this bug (since there are legitimate issues with the imagery of the old design).
(In reply to comment #13)
> There is also another new Mozilla shirt in the works that is also influenced by
> the Hack shirt (there is a star, there is a dino-head, the colors are white,
> red and orange).  More news on this shirt should be available soon.
Here's what this art looks like...it was directly inspired by the Hack shirts, but we tried to take out the overtly communistic imagery:
http://www.intothefuzz.com/2008/06/13/celebrating-10-years-of-mozilla/
I think that's a great shirt for the 10 year anniversary, and the artwork in it does do a great job of keeping the old feel, but... it's not the same message (textwise) as the Hack t-shirts.
Re comment #15, the 10 year anniversary shirt doesn't have any additional text, but the other new Mozilla shirt was designed to have a similar message as the Hack shirt.  IMO, the tag line "Internet by the people for the people" has a similar people-powered message as "This technology could fall into the right hands".
Is there some reference that makes "This technology could fall into the right hands" taboo that I'm not familiar with?

I really like it and the sentiment is a lot more powerful to me than by the people for the people. These days we always worry about new technology falling into the wrong hands, good vs evil etc. It's very thought provoking to change the "wrong" to "right."

The new saying is good, too, don't get me wrong, but it's also very American.  I know it can't be changed now, but for future consideration and other products I agree with fantasai that the old saying is worth keeping around.
No, there's nothing taboo (that I'm aware of) with the old line from the Hack shirt and we can certainly keep it around for use in the future.
I completely agree with Lucy's comment 17. Another thing about the new t-shirt, it's a very good representation of the Mozilla Foundation and our broad mission in that sense, but not so much of the technology-based open source origins of the Mozilla project.

You could say that one of my gripes about the current line of t-shirts is that as a platform developer, I feel left out. We need something that all our non-Firefox devs can wear and be proud of. "By the people, For the people" comes very close, but imho not quite there.
To really do this right, we should just reprint the original Hack shirts. Nothing before or after was a clean and profound a piece of art and nothing before or since has spoken to _that_ audience as well.  

Mozilla Classic Tees FTW!!
(In reply to comment #20)
> To really do this right, we should just reprint the original Hack shirts.
...
> Mozilla Classic Tees FTW!!

+1
As fantasai mentions in comment #19, the Mozilla community's mission in 2008 is a lot more broad than it was in 1998.  Back then the project was focused on creating technology, but now it goes beyond that.  Using the old technology tag-line from the Hack shirt today would leave out any information about the values that are also important to us.

That having been said, I think also having a shirt focused on platform developers that was just about the technology is a good idea.  I personally don't think that it makes sense to have that shirt be an exact reprint of the old Hack shirt -- it should be close to it in design and in spirit, but reprinting the shirt exactly as it was seems like it would send a signal that we are ignoring the concerns of a big chunk of the community.
(In reply to comment #22)
> old Hack shirt -- it should be close to it in design and in spirit, but
> reprinting the shirt exactly as it was seems like it would send a signal that
> we are ignoring the concerns of a big chunk of the community.

How is reprinting the Hack shirt ignoring anyone? Care to elaborate? I'm not suggesting replacing a current Firefox or Thunderbird or Bugzilla shirt with the Hack tee. It's additive. That doesn't fit with "ignoring" in my book.
As mentioned in comment #7 and #9, the red star in the Hack shirt upset some people because of it's association with communism.  This is the sentiment I didn't want to ignore by reprinting the Hack shirt exactly as is.

Personally, I think the old Hack shirt is great but it isn't necessarily the apex of possible Mozilla shirt designs.  As I mentioned earlier, I think the best fix for this bug is to design new shirts that borrow heavily from the Hack shirt.
It shouldn't be hard to narrow down criteria for people who should have the old hack tshirts and reprint them specially for them.

Reprinting them exactly simply to sell them again doesn't seem practical and it makes the existing ones less special.

In this respect I agree with David for sure. New shirts for new community members shouldn't be the same as it's just not the same in any regard.

An interesting solution might be to see if the work can be licensed such that people can have their own shirts printed at their own expense.

(on a side note, "The Internet could fall into the right hands" is an interesting tagline to me, though there's probably a better place than this bug to suggest it)
store.mozilla.org has been closed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.