Closed Bug 385526 Opened 12 years ago Closed 12 years ago

Crash [@ gfxSkipCharsIterator::SetOffsets] with ::first-line, display: inline, white-space: nowrap on body and removing style

Categories

(Core :: Layout, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: martijn.martijn)

References

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(1 file)

Attached file testcase
See testcase, which usually crashes current trunk builds within 400ms.
This regressed when the new textframe patch landed.

https://crash-reports.mozilla.com/reports/report/index/a60b902b-210b-11dc-95f4-001a4bd43ef6
0  	gfxSkipCharsIterator::SetOffsets(unsigned int,int)
1 	BuildTextRunsScanner::SetupBreakSinksForTextRun(gfxTextRun *,int,int)
2 	BuildTextRunsScanner::FlushFrames(int)
3 	BuildTextRunsScanner::ScanFrame(nsIFrame *)
4 	BuildTextRunsScanner::ScanFrame(nsIFrame *)
5 	BuildTextRuns
6 	nsTextFrame::EnsureTextRun(nsIRenderingContext *,nsIFrame *,nsLineList_iterator const *,unsigned int *)
7 	nsTextFrame::Reflow(nsPresContext *,nsHTMLReflowMetrics &,nsHTMLReflowState const &,unsigned int &)
8 	nsLineLayout::ReflowFrame(nsIFrame *,unsigned int &,nsHTMLReflowMetrics *,int &)
9 	nsInlineFrame::ReflowInlineFrame(nsPresContext *,nsHTMLReflowState const &,nsInlineFrame::InlineReflowState &,nsIFrame *,unsigned int &)
Looks like bug 386584
Depends on: 386584
This is still crashing with current trunk build.
From the comments in bug 386584, I guess this could be fixed by bug 385270.
Depends on: 385270
Bug 385270 was fixed, but I'm still crashing with current trunk build. It can take a few reloads, though (it reloads automatically).
http://crash-stats.mozilla.com/report/index/02d8a57a-3e3c-11dc-9f68-001a4bd46e84
0  	gfxSkipCharsIterator::SetOffsets(unsigned int,int)
1 	BuildTextRunsScanner::SetupBreakSinksForTextRun(gfxTextRun *,int,int)
2 	BuildTextRunsScanner::FlushFrames(int)
3 	BuildTextRunsScanner::ScanFrame(nsIFrame *)
4 	BuildTextRunsScanner::ScanFrame(nsIFrame *)
5 	BuildTextRuns
6 	nsTextFrame::EnsureTextRun(nsIRenderingContext *,nsIFrame *,nsLineList_iterator const *,unsigned int *)
7 	nsTextFrame::Reflow(nsPresContext *,nsHTMLReflowMetrics &,nsHTMLReflowState const &,unsigned int &)
8 	nsLineLayout::ReflowFrame(nsIFrame *,unsigned int &,nsHTMLReflowMetrics *,int &)
9 	nsInlineFrame::ReflowInlineFrame(nsPresContext *,nsHTMLReflowState const &,nsInlineFrame::InlineReflowState &,nsIFrame *,unsigned int &)
Flags: blocking1.9?
roc is fixing this over in bug 385270.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385270
Ok, I guess.
But the last time bug 385270 was fixed, this crash was still there.
Flags: in-testsuite?
Oh, sorry.  Let me reopen then; I shouldn't assume.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Firefox crashes whenever clicking on "View 4 replies" in the first comment on this site: http://www.digg.com/tech_news/See_Who_s_Editing_Wikipedia_Diebold_the_CIA_a_Campaign

using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081505 Minefield/3.0a8pre ID:2007081505

http://crash-stats.mozilla.com/report/index/a6845b42-4b8e-11dc-bfd9-001a4bd43ef6

0 gfxSkipCharsIterator::SetOffsets(unsigned int, int)
1 BuildTextRunsScanner::SetupBreakSinksForTextRun(gfxTextRun*, int, int)
2 BuildTextRunsScanner::BuildTextRunForFrames(void*)
3 BuildTextRunsScanner::FlushFrames(int)
4 BuildTextRuns
5 nsTextFrame::EnsureTextRun(nsIRenderingContext*, nsIFrame*, nsLineList_iterator const*, unsigned int*)
6 nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&)
7 nsLineLayout::ReflowFrame(nsIFrame*, unsigned int&, nsHTMLReflowMetrics*, int&)
8 nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&, nsLineLayout&, nsLineList_iterator, nsIFrame*, LineReflowStatus*)
9 nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState&, nsLineLayout&, nsLineList_iterator, int*, LineReflowStatus*, int)

Similar stacktrace to above or rather Bug 386584 ?
Not crashing anymore, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081605 Minefield/3.0a8pre

Fixed by bug 385270.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Confirmed Fixed with my digg.com example mentioned above
Crash Signature: [@ gfxSkipCharsIterator::SetOffsets]
Crash test:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8d965e3893b4
Flags: in-testsuite?
Flags: in-testsuite+
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.