Closed Bug 385549 Opened 16 years ago Closed 16 years ago

various cycle collector debugging patches, round 2

Categories

(Core :: XPCOM, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: dbaron)

Details

(Whiteboard: [patch])

Attachments

(4 files)

Here's another round of cycle collector debugging patches.  My previous round was bug 383234.  Except for the first one, which I've had around for a while, these are the patches I used to debug the leak regression from bug 381199, which is now filed as bug 385548.
This makes it easier to correlate pointers between different types of debugging output.
Attachment #269467 - Flags: superreview?(jst)
Attachment #269467 - Flags: review?(jst)
This adds an nsCycleCollector_DEBUG_shouldBeFreed for the outer window, useful for ExplainLiveExpectedGarbage.  (These don't need to be perfect, but they're true in most cases.)
Attachment #269468 - Flags: superreview?(jst)
Attachment #269468 - Flags: review?(jst)
This adds an nsCycleCollector_DEBUG_shouldBeFreed for elements, useful for ExplainLiveExpectedGarbage.  (These don't need to be perfect, but they're true in most cases.)
Attachment #269469 - Flags: superreview?(jst)
Attachment #269469 - Flags: review?(jst)
This is the fun one.

The bugs mentioned in comment 0 are the first time I hit the warning about failure to unlink or suspect, and they weren't too useful because they print warnings for the entire graph of objects that would be freed.  This determines the strongly connected components of the graph and prints them only for the objects in the root components, which are the ones we care about.  And it even prints component identifiers so you can see which are related to each other.
Attachment #269470 - Flags: review?(graydon)
Summary: various cycle collector debugging patches → various cycle collector debugging patches, round 2
Attachment #269470 - Flags: review?(graydon) → review+
Whiteboard: [patch]
Attachment #269467 - Flags: superreview?(jst)
Attachment #269467 - Flags: superreview+
Attachment #269467 - Flags: review?(jst)
Attachment #269467 - Flags: review+
Attachment #269468 - Flags: superreview?(jst)
Attachment #269468 - Flags: superreview+
Attachment #269468 - Flags: review?(jst)
Attachment #269468 - Flags: review+
Attachment #269469 - Flags: superreview?(jst)
Attachment #269469 - Flags: superreview+
Attachment #269469 - Flags: review?(jst)
Attachment #269469 - Flags: review+
Attachment #269470 - Flags: superreview+
All patches now checked in.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.