Closed Bug 385745 Opened 14 years ago Closed 14 years ago

breakpad landing broke --disable-compile-environment

Categories

(Toolkit Graveyard :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Pike, Assigned: Pike)

Details

Attachments

(1 file)

From bug 380540 comment 20:

Attachment 269250 [details] [diff] broke --disable-compile-environment again, sadly. I guess the
extra error message should be if test_libs or whatever that is called. Bug
383463 shows how I fixed this just recently.

This turned the trunk builds on http://l10n.mozilla.org/buildbot/ red.
Hrm, I don't think that I should have to pick up other peoples regressions, but that's life, huh?
Assignee: nobody → l10n
Status: NEW → ASSIGNED
Attachment #270004 - Flags: review?
Attachment #270004 - Flags: review? → review?(ted.mielczarek)
Comment on attachment 270004 [details] [diff] [review]
don't error on libcurl if testlibs isn't set

c'est la vie, no?
Attachment #270004 - Flags: review?(ted.mielczarek) → review+
Axel, if you'd like to propose new tree rules please do so on the newsgroups.
Checked in.

Regarding the tree rules, it's a tad involved to actually create a tree rule without having a tinderbox and a descent error condition. I guess that doing a lorem ipsum yadda locale dynamically and then rebuilding that could give results independent of particular localizations and might be the right indicator. IIRC, gandalf had something, I have something, I should have a look at it one day.

Right now, it'd be great if the two of you would just keep an eye on this on the review side.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.