SOAPAction Header on submission is not being set

RESOLVED FIXED

Status

Core Graveyard
XForms
--
major
RESOLVED FIXED
10 years ago
a year ago

People

(Reporter: Keith, Assigned: aaronr)

Tracking

({fixed1.8.1.5})

Trunk
x86
Windows XP
fixed1.8.1.5

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

3.50 KB, application/xhtml+xml
Details
1.33 KB, patch
Doron Rosenberg (IBM)
: review+
smaug
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Sidewinder 1.0; formsPlayer 2.0; formsPlayer 1.4; SV1; formsPlayer 1.5; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 

Reference https://bugzilla.mozilla.org/show_bug.cgi?id=309442.  The code to support the SOAPAction header based upon the XForms 1.1 spec. was added to xforms.xpi 0.8.0.1.  Using a SOAP monitor and the test case from 309442, the SOAPAction header was not being viewed in the http headers.  Discussed the problem with Aaron, who subsequently debugged the problem. He said "we are testing the DOMDocument.  We should be checking against the document's documentElement".  Please reference the SerializeDataXML method where the nodeNS and nodeName are tested to determine if the node of the instance is in the SOAP Namespace and is the SOAP "Envelope" element. 

Reproducible: Always

Steps to Reproduce:
1.See Test case
(Reporter)

Comment 1

10 years ago
Created attachment 269735 [details]
Web Service submission from XForms
(Assignee)

Updated

10 years ago
Component: Extension Compatibility → XForms
Product: Firefox → Core
QA Contact: extension.compatibility → xforms
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Assignee: nobody → aaronr
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

10 years ago
Created attachment 269738 [details] [diff] [review]
patch

Simple fix as it turns out.  We were incorrectly looking for SOAPEnvelope on the the document instead of the documentElement.  Doh!
Attachment #269738 - Flags: review?(doronr)
(Assignee)

Updated

10 years ago
Attachment #269738 - Flags: review?(Olli.Pettay)

Comment 3

10 years ago
Comment on attachment 269738 [details] [diff] [review]
patch

oops. Regression from Bug 338314 ?
Attachment #269738 - Flags: review?(Olli.Pettay) → review+

Updated

10 years ago
Attachment #269738 - Flags: review?(doronr) → review+
(Assignee)

Comment 4

10 years ago
fix committed to trunk and 1.8 branch
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.1.5
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.