If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tengwar tehtar signs are displayed below base letter

RESOLVED WORKSFORME

Status

()

Core
Internationalization
P3
normal
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: TAKAHASHI Makoto, Assigned: smontagu)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m15)
BuildID:    2000041805

I downloaded font from
http://www.geocities.com/TimesSquare/4948/
and install to Windows 2000.
Then I can see tehter character in page above by Netscape Navigator 4.7, But I
cannot see them by Mozilla.


Reproducible: Always
Steps to Reproduce:
1.Install Tolkien font from
 http://www.geocities.com/TimesSquare/4948/
2.view page

Actual Results:  Tehter font is not displayed

Expected Results:  Tehter font is displayed.
Changing component to Internationalization, although I this may well be a bug in
NN 4.x and not a bug in Mozilla.
Assignee: asadotzler → ftang
Component: Browser-General → Internationalization
QA Contact: jelwell → teruko
(Reporter)

Comment 2

18 years ago
This problem is reptoduced for Microsoft proper fonts.

 You can not view U+0300, U+0301, U+0302,...
 They are displayed by Netscape Navigator 4.7 and Internet Explorer 5.


http://homepage1.nifty.com/hobbit/english/html/ipa.html#combin

Comment 3

18 years ago
erik- please take a look at this. Add cata to the cc list since he now also 
support win/gtk font rendering.
Assignee: ftang → erik
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Created attachment 9513 [details]
base letter followed by combining mark in separate <span>

Comment 5

18 years ago
The URL mentioned above (.../sind.html) refers to a font called Tengwar Sindarin
that is used to write the Sindarin language in the Tengwar script, invented by
J.R.R.Tolkien for his books, including "The Lord of the Rings". See:

  http://anubis.dkuug.dk/jtc1/sc2/wg2/docs/n1641/n1641.htm

The font itself is somewhat unusual, since it has Tengwar glyphs in standard
Unicode positions in the Latin-1 range (U+0000 -- U+00FF). Some of those glyphs
are intended to be used as non-spacing marks. Here is a snippet of HTML from
the URL above:

  <span class=tngsb>.</span><span class=tngs>0</span>

This looks like an 'o' with a tilde '~' above it in IE5 and Nav4. In Mozilla,
the tilde ends up below the 'o'.

A similar effect can be seen in Mozilla when you have an actual Unicode
combining diacritical mark after an ordinary base letter that is in a separate
<span>. See the attachment.

When you view that attachment in IE5, the base letter and combining mark are
combined to form a single precomposed glyph, displayed in blue. In Nav4, the two
are not combined, and the letter is blue while the mark is black and not
centered above the letter. It is not clear to me whether IE's behavior is
correct as far as the HTML spec is concerned. (The letter and mark are in
separate <span>s. What is the spec for this?)

Accepting bug, setting target to Future.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

18 years ago
Summary: Tehter of Tolkien font is not displayed → Tengwar tehtar signs are displayed below base letter

Comment 6

18 years ago
This particular bug report is really dealing with normal characters (e.g. '.'
followed by '0'), but the font has special glyphs for some of the characters
(e.g. '0'). Those glyphs probably have special metrics that cause them to be
displayed above the previous glyph in normal usage, but when they are in
separate <span>s, Mozilla draws them *under* the base letter. This is quite
different from the issue of having a Unicode base letter and a Unicode combining
mark in separate <span>s.

Comment 7

18 years ago
Created attachment 9519 [details]
letter and sign together, and in separate <span>s

Comment 8

18 years ago
It turns out that these combining marks have a zero width. This may be confusing
Mozilla.
(Reporter)

Comment 9

17 years ago
This problem is reproduced on Build 2000101212.

Comment 10

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW

Comment 11

17 years ago
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED
reporter, does this repro on 1.7 RC1 or latest build??
(Reporter)

Comment 13

14 years ago
Yes, it is reproduced in 2004050808.

No font is displayed for

http://homepage1.nifty.com/hobbit/tolkien/tengwar/sind.html

Comment 14

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 15

13 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 16

13 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: ftang → nobody
Status: REOPENED → NEW
Filter on "Nobody_NScomTLD_20080620"
Assignee: nobody → smontagu
QA Contact: teruko → i18n
(Assignee)

Comment 18

9 years ago
Created attachment 326260 [details]
Testcase

Testcase using fonts from http://home.student.uu.se/j/jowi4905/fonts/annatar.html
(Assignee)

Comment 19

9 years ago
There are two or three different issues with these fonts, all of which have their own bugs and all of which are fixed already.
Status: NEW → RESOLVED
Last Resolved: 13 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.