reftest comparing dataURI to identical dataURI does not pass equality test

REOPENED
Unassigned

Status

defect
REOPENED
12 years ago
11 years ago

People

(Reporter: ray, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Running on trunk build of firefox, fetched yesterday.

See the enclosed reftest.list. It just contains:

== (a data URI) (the same data URI)

A data URI, when compared to itself, should pass a test for being equal, yes?
Attachment #269798 - Attachment mime type: application/octet-stream → text/plain
Why do you have "==" on the end of each data: URI? Does it work when you remove those?
The "==" on the end of the data URI is there because that is what reftest gave me. When there is a failure in a reftest test, it dumps out the data URI. I took a data URI that it dumped out and pasted it onto one line, twice, with a "==" at the beginning of the line.

I have an edit to reftest that lets it load png image files and successfully compares a rendered page and a PNG file. However, it as suggested that we should use data URIs instead of PNG files. Taking this to heart, I thought that using data URIs would work. However, I find that they do not.

I tried taking the "==" off the end of each URI and it still failed.
Yeah, sorry. Gavin tells me the "==" is added for padding.

Some of the existing tests use an <img> element with the src attribute being a data URI [0]. Would this be an acceptable alternative?

[0] http://mxr.mozilla.org/seamonkey/source/layout/reftests/bugs/370629-1.html
It does work to put the data URI into an image tag. It is a bit awkward, though.
This is too much like this other bug to keep open. Closing as dupe.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376628
I don't think this is a dup of bug 376628.  Bug 376628 was about comparing HTML to an image and occurs because of padding added to the image.  This bug is about comparing an image to an identical image, and we don't know what causes it.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Using the <img> tag does work in some cases but it does not in others. If there is a colored background to a page, for example, the reftest image crops the background color at the edge of the image.

If your page has no background, then one does seem to be able to use the <img> tag workaround, but it is not a very good work-around. Attaching html page that demonstrates the problem.
Component: Testing → Reftest
Product: Core → Testing
QA Contact: testing → reftest
You need to log in before you can comment on or make changes to this bug.