css colored table borders with :hover useage has unexpected border color changing results

RESOLVED DUPLICATE of bug 286797

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 286797
11 years ago
10 years ago

People

(Reporter: Hughman, Unassigned)

Tracking

({css2, testcase})

1.8 Branch
x86
Windows Vista
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When moving my mouse around on the following (border-collapsed) table (which is a very specific example from a larger private page) the border changes color but never as expected. The fist problem I noticed was when I move my cursor from the 2nd cell to the top one the entire sides of the table are changed color. As I was investigating it I noticed that the other cells were not changing there side borders when moused over.

Reproducible: Always

Steps to Reproduce:
1. Put mouse over cells other than top one. Notice only bottom border changes color.
2. Move mouse directly to top cell. Notice side borders on cells below top cell change color too.
Actual Results:  
Borders dont change color as expected.

Expected Results:  
Each cell should have all its borders change colour (except possibly the top border of cells with a cell above it, that one is owned by the above cell) but none of the other borders should be colored.

<html><head><style type="text/css">
.ball { border: 1px solid #111111; }
table { border-collapse: collapse; }
tr:hover td { border: 1px solid #eebb99; }
</style></head><body><table>
<tr>
<td class="ball">Folder at 1</td>
</tr>
<tr>
<td class="ball">Folder at 2</td>
</tr>
<tr>
<td class="ball">Folder at 3</td>
</tr>
</table></body></html>
(Reporter)

Updated

11 years ago
Keywords: css2
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
Created attachment 269840 [details]
The specific Example which Contains the Bugs
(Reporter)

Updated

11 years ago
Attachment #269840 - Attachment description: The specific Example with Contains the Bugs → The specific Example which Contains the Bugs

Updated

11 years ago
Component: General → Style System (CSS)
Keywords: testcase
Product: Firefox → Core
QA Contact: general → style-system
Version: 2.0 Branch → 1.8 Branch
(Reporter)

Comment 2

11 years ago
I have now half upgraded to Vista and the test case above still gives the unexpected results. So I'm changing the OS to vista since its more important than old win98.
(Reporter)

Comment 3

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
OS: Windows 98 → Windows Vista

Comment 4

10 years ago
The collapsed border model is a mess in Mozilla. Cross your fingers and hope it'll be fixed in this or the next decade...

It wasn't easy but this bug is a dupe of Bug 286797 (the last testcase essentially got the same bug).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286797
You need to log in before you can comment on or make changes to this bug.