Closed Bug 386155 Opened 13 years ago Closed 12 years ago

effective TLD service doesn't clean up on shutdown

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9alpha8

People

(Reporter: dbaron, Assigned: dwitte)

References

Details

(Keywords: memory-leak)

The effective TLD service doesn't clean up any of its storage on shutdown -- it's all in the static variable sSubdomainTreeHead.

This, along with bug 386154, are the cause of the leak regression from bug 366797.  It's probably best to fix both at the same time.
Flags: blocking1.9?
Blocks: 366797
Blocks: 367373, 385299
Depends on: 386154
will fix as part of bug 386154.
Assignee: nobody → dwitte
Target Milestone: --- → mozilla1.9beta1
Flags: blocking1.9? → blocking1.9+
fixed for 1.9a7 as part of bug 386154.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.