crashreporter expects "Vendor" to be existing

RESOLVED DUPLICATE of bug 396209

Status

()

RESOLVED DUPLICATE of bug 396209
11 years ago
11 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
crashreporter expects "Vendor" to be existing

Vendor is an optional field in application.ini but if it's not set the crash reporter on Windows saves to the registry key Software\Crash Reporter and therefore treats Vendor to be mandatory.
(Reporter)

Comment 1

11 years ago
I wonder if
http://mxr.mozilla.org/seamonkey/source/toolkit/airbag/client/crashreporter_win.cpp#699
was intended to fall back to Software\Mozilla\Crash Reporter but doesn't do it because Vendor could be found in gQueryParameters but is empty?
(Reporter)

Comment 2

11 years ago
Aehm, forgot my proposal: Fall back to product/Name/ProductName if Vendor is
empty/not defined.

Looks like we should probably be testing the string here to see if it's an empty string:
http://mxr.mozilla.org/seamonkey/source/toolkit/xre/nsAppRunner.cpp#2524

But this might be obviated by bent's fix over on bug 396486.
Rolled into the patch on bug 396209.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 396209
You need to log in before you can comment on or make changes to this bug.