Improper parsing of unknown elements containing block level elements

RESOLVED DUPLICATE of bug 311366

Status

()

RESOLVED DUPLICATE of bug 311366
12 years ago
12 years ago

People

(Reporter: jeff.cutsinger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Block level elements that should be children of unknown elements end up as their siblings. Though I have no real knowledge of gecko internals, it appears as though the elements are automatically closing when they run into a block-level element. The consequences of this being that any new or experimental languages (specifically HTML5) don't work.

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311366
You need to log in before you can comment on or make changes to this bug.